OUR FINDINGS
Organizations deploying virtual desktops must weigh the benefits of different classes of clients. As computing needs grow over time, an investment in PC clients can meet the needs of increasing categories of workers. In Principled Technologies’ tests in our labs, an Intel® Core™ vPro™ processor-based PC delivered an excellent user experience while playing advanced multimedia workloads within a virtual desktop infrastructure (VDI) session. Such clients would serve a company well today and for years to come.

OUR PROCESS
To evaluate the user experience when running VDI sessions from four different clients, we rated the video and audio quality of various workloads, including multimedia and printing, in the VDI virtual machines. For testing, we played a video inside the virtual desktop and monitored the video and audio quality. In addition, we recorded the frames per second while the video played.
PROJECT OVERVIEW

The goal of this report is to communicate the multimedia performance benefits of using PCs to run virtual desktops from Citrix XenDesktop 4 with HDX MediaStream. PCs can utilize their own processors and graphics processing units to offload multimedia workloads in a virtual desktop environment when multimedia redirection (MMR) is enabled. HDX MediaStream is MMR technology from Citrix that lets physical clients use their local hardware to format and play media content. This greatly reduces server CPU usage and demonstrates one of the benefits of intelligent PC clients as VDI end-points.

We tested the VDI performance of four classes of clients by selecting a leading representative system from each:

- **Mainstream business laptop**: HP EliteBook 8440p with Intel Core i5-520M vPro processor (2.40 GHz)
- **Netbook**: HP Mini 5102 with Intel Atom™ N450 processor (1.66 GHz)
- **Thin client**: Wyse C90LEW with VIA Eden™ 1.00 GHz processor (1.00 GHz)
- **Zero client**: Wyse Xenith™ with VIA Eden 1.00 GHz processor (1.00 GHz)

We ran four advanced multimedia workloads on each system. As Figure 1 shows, the Intel Core vPro processor-based PC delivered better multimedia experiences than other client classes. We present detailed results and explain our ratings in the What We Found section below.

![Figure 1: User-experience results for the four classes of clients we tested.](image-url)
WHAT WE TESTED

About multimedia redirection

Multimedia redirection is a technology that lets physical clients use their local CPUs and graphics cards to format and play media content. Without MMR, this processing demand is on the hosting server, thus causing the server to utilize more resources per virtual desktop. For testing, we ran with MMR enabled on all clients; MMR was supported in all test scenarios except the Adobe® Flash® video workload on the Wyse C90LEW and Wyse Xenith clients. For more information on Flash support, see the What We Found section. For information about the benefits MMR provides for virtual desktop deployments, including the reduction of server utilization, please see our corresponding report at http://www.principledtechnologies.com/clients/reports/Intel/MMR_effect_VDI_Xen_1010.pdf.

About Citrix XenDesktop

For our VDI solution, we used Citrix XenDesktop 4 with Feature Pack 2 (released on 09/29/2010) on an Intel Xeon processor 5570-based server with 24GB memory and gigabit network connection. According to the Citrix Web site, XenDesktop provides a flexible computing experience for users while helping organizations address key business priorities. Easy access to complete virtualized desktops, applications, and data from any location, using any device enables more productive and mobile virtual work styles and inspires innovation throughout the business. For more information on XenDesktop, see http://www.citrix.com/xd4.

How we tested Citrix XenDesktop

To test the performance of the four clients running XenDesktop with HDX, we used the following advanced multimedia workloads:

- Robotica video at 1080p while running a print job

We rated the video and audio quality of each video workload on each client. We installed Beepa® Fraps® on the clients to record the average frames per second (FPS) rate that each client achieved, and assigned overall quality scores based on the quality of the video and audio on each client.
We chose advanced multimedia workloads at 720p and 1080p to measure the user experience capabilities of the various client classes because a company looking to deploy a VDI solution needs to ensure that their virtual desktop clients will be able to handle the computing needs of their workers not only today, but into the future as well. While the typical virtual desktop user may not regularly play 720p or 1080p videos, ensuring that clients can meet these more advanced needs will ensure that most user demands can be met today while preparing for future computing needs.

To determine the user experience each client delivered while completing multiple tasks, as a typical virtual desktop user would, we played the Robotica video at 1080p while simultaneously running a print job. We opened a target PDF file, selected Print, started the video, returned to the Print PDF screen, and clicked OK, to ensure that the print job executed while the video was running.

Finally, we configured a dual-socket server and gigabit LAN environment in such a way that it did not interfere with client performance. To ensure further that our testing focused on client performance, we ran only one virtual desktop for each test. For detailed server configuration information, see Appendix A. For detailed client configuration information, see Appendix B. For our detailed test methodology, see Appendix C.

**WHAT WE FOUND**

Figure 2 lists the ratings we use to describe the video and audio qualities of the workloads, and the criteria we used to determine each rating.

<table>
<thead>
<tr>
<th>Rating</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Best</td>
<td>Essentially flawless audio and video quality</td>
</tr>
<tr>
<td>Very good</td>
<td>Near-perfect quality, with some minor syncing or skipping issues</td>
</tr>
<tr>
<td>Adequate</td>
<td>Moderate syncing or skipping issues</td>
</tr>
<tr>
<td>Poor</td>
<td>Severe syncing or skipping issues; practically unwatchable</td>
</tr>
</tbody>
</table>

*Figure 2: Ratings we used for our workload testing and their meanings.*

In addition to rating the video and audio quality of the advanced multimedia workloads, we also recorded the average FPS as we note earlier. An average FPS rate of around 30 FPS indicates the best video quality, while anything less than 30 FPS indicates that the video performance likely suffered. Please note that we were unable to record average FPS rates from the Wyse C90LEW because its embedded operating system is incapable of running the Fraps program. We were unable to record average FPS rates from the Wyse Xenith zero client because the system is unable to host an operating system.
We used HDX Monitor to determine whether the server actually redirected the multimedia workloads to the client. We found that while the server redirected the 720p and 1080p videos to all the clients, it redirected the Flash workload to only the HP Elitebook 8440p and the HP Mini 5102. The server could redirect Flash to the HP systems because they ran full Microsoft Windows® 7 operating systems that hosted a Flash player. Because the Wyse C90LEW ran Windows XP Embedded and the Wyse Xenith did not run an OS, they could not host a Flash player and the server could not redirect the Flash workload.

Figure 3 shows the video playback results for the clients at 720p. The HP EliteBook 8440p and HP Mini 5102 displayed perfect audio and video quality, while the Wyse C90LEW displayed video hesitations with completely out-of-sync audio, and the Wyse Xenith zero client displayed choppy video and out-of-sync audio throughout the clip.

<table>
<thead>
<tr>
<th>Client</th>
<th>Video quality</th>
<th>Audio quality</th>
<th>Avg. FPS</th>
</tr>
</thead>
<tbody>
<tr>
<td>HP EliteBook 8440p</td>
<td>Best</td>
<td>Best</td>
<td>30</td>
</tr>
<tr>
<td>HP Mini 5102</td>
<td>Best</td>
<td>Best</td>
<td>30</td>
</tr>
<tr>
<td>Wyse C90LEW</td>
<td>Very Good</td>
<td>Poor</td>
<td>N/A</td>
</tr>
<tr>
<td>Wyse Xenith</td>
<td>Poor</td>
<td>Adequate</td>
<td>N/A</td>
</tr>
</tbody>
</table>

Figure 3: Video playback test results at 720p for the test clients.

Figure 4 shows the video playback results for the clients at 1080p. The HP EliteBook 8440p displayed perfect audio and video quality, while the HP Mini 5102 video displayed the picture somewhat slowly with audio missing or out-of-sync at times. The Wyse C90LEW displayed video that hesitated with completely out-of-sync audio, and the Wyse Xenith zero client played extremely choppy video with audio out-of-sync throughout.

<table>
<thead>
<tr>
<th>Client</th>
<th>Video quality</th>
<th>Audio quality</th>
<th>Avg. FPS</th>
</tr>
</thead>
<tbody>
<tr>
<td>HP EliteBook 8440p</td>
<td>Best</td>
<td>Best</td>
<td>30</td>
</tr>
<tr>
<td>HP Mini 5102</td>
<td>Very Good</td>
<td>Adequate</td>
<td>25</td>
</tr>
<tr>
<td>Wyse C90LEW</td>
<td>Adequate</td>
<td>Poor</td>
<td>N/A</td>
</tr>
<tr>
<td>Wyse Xenith</td>
<td>Poor</td>
<td>Poor</td>
<td>N/A</td>
</tr>
</tbody>
</table>

Figure 4: Video playback test results at 1080p for the test clients.

Figure 5 shows the video playback and print job results for the clients at 1080p. The HP EliteBook 8440p played perfect video and audio, while the HP Mini 5102 had the audio skip as the print job happened,
with the audio finishing well before the choppy video. Both the Wyse C90LEW and the Wyse Xenith zero client played extremely choppy video with audio that hesitated and was out-of-sync throughout.

<table>
<thead>
<tr>
<th>Client</th>
<th>Video quality</th>
<th>Audio quality</th>
<th>Avg. FPS</th>
</tr>
</thead>
<tbody>
<tr>
<td>HP EliteBook 8440p</td>
<td>Best</td>
<td>Best</td>
<td>30</td>
</tr>
<tr>
<td>HP Mini 5102</td>
<td>Poor</td>
<td>Adequate</td>
<td>15</td>
</tr>
<tr>
<td>Wyse C90LEW</td>
<td>Poor</td>
<td>Poor</td>
<td>N/A</td>
</tr>
<tr>
<td>Wyse Xenith</td>
<td>Poor</td>
<td>Poor</td>
<td>N/A</td>
</tr>
</tbody>
</table>

Figure 5: Video playback with print job test results at 1080p for the test clients.

Figure 6 shows the Flash video results for the clients. On our Flash video test, audio and video quality remained nearly perfect across the clients, with only a slight hesitation in the videos for the Wyse C90LEW thin client and Wyse Xenith zero client. As we state earlier, the server redirected the Flash content to only the HP systems; for the Wyse systems, the server rendered the Flash content playback. The results we report reflect a load of only a single user; video and audio quality might change as users are added in a typical configuration.

<table>
<thead>
<tr>
<th>Client</th>
<th>Video quality</th>
<th>Audio quality</th>
<th>Avg. FPS</th>
</tr>
</thead>
<tbody>
<tr>
<td>HP EliteBook 8440p</td>
<td>Best</td>
<td>Best</td>
<td>30</td>
</tr>
<tr>
<td>HP Mini 5102</td>
<td>Best</td>
<td>Best</td>
<td>30</td>
</tr>
<tr>
<td>Wyse C90LEW</td>
<td>Very Good</td>
<td>Best</td>
<td>N/A</td>
</tr>
<tr>
<td>Wyse Xenith</td>
<td>Very Good</td>
<td>Best</td>
<td>N/A</td>
</tr>
</tbody>
</table>

Figure 6: Flash test results for the test clients.

For CPU utilization and throughput data we recorded during our tests, please see Appendix D.

**SUMMARY**

Of the four client systems we tested for Citrix XenDesktop 4 with HDX, the HP EliteBook 8440p with Intel Core i5-520M vPro processor provided the best user experience. Not only did this system achieve the highest quality audio and video across the four advanced multimedia workloads we tested, it did so using its own local hardware to format and play media content. A large-scale deployment of these notebook PC systems would provide workers with excellent multimedia experiences while greatly reducing server CPU usage.
APPENDIX A – SERVER CONFIGURATION INFORMATION

Figure 7 provides detailed configuration information about the test server.

<table>
<thead>
<tr>
<th>System</th>
<th>Super Micro 6026T-NTR+</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Power supplies</strong></td>
<td></td>
</tr>
<tr>
<td>Total number</td>
<td>2</td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>SuperMicro PWS-721P-R1</td>
</tr>
<tr>
<td>Wattage of each (W)</td>
<td>720</td>
</tr>
<tr>
<td><strong>Cooling fans</strong></td>
<td></td>
</tr>
<tr>
<td>Total number</td>
<td>3</td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>Sanyo Denki San Ace 80 9G0812P1G09</td>
</tr>
<tr>
<td>Dimensions (h x w) of each</td>
<td>3-1/4’ x 3-1/4</td>
</tr>
<tr>
<td>Volts</td>
<td>12</td>
</tr>
<tr>
<td>Amps</td>
<td>1.1</td>
</tr>
<tr>
<td><strong>General</strong></td>
<td></td>
</tr>
<tr>
<td>Number of processor packages</td>
<td>2</td>
</tr>
<tr>
<td>Number of cores per processor</td>
<td>4</td>
</tr>
<tr>
<td>Number of hardware threads per core</td>
<td>2</td>
</tr>
<tr>
<td>System power management policy</td>
<td>Balanced</td>
</tr>
<tr>
<td><strong>CPU</strong></td>
<td></td>
</tr>
<tr>
<td>Vendor</td>
<td>Intel</td>
</tr>
<tr>
<td>Name</td>
<td>Xeon</td>
</tr>
<tr>
<td>Model number</td>
<td>X5570</td>
</tr>
<tr>
<td>Stepping</td>
<td>D0</td>
</tr>
<tr>
<td>Socket type</td>
<td>LGA 1366</td>
</tr>
<tr>
<td>Core frequency (GHz)</td>
<td>2.93</td>
</tr>
<tr>
<td>Bus frequency</td>
<td>6.4 GT/s</td>
</tr>
<tr>
<td>L1 cache</td>
<td>32 KB + 32 KB (per core)</td>
</tr>
<tr>
<td>L2 cache</td>
<td>256 KB (per core)</td>
</tr>
<tr>
<td>L3 cache</td>
<td>8 MB (shared)</td>
</tr>
<tr>
<td><strong>Platform</strong></td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>SuperMicro 6026T-NTR+</td>
</tr>
<tr>
<td>Motherboard model number</td>
<td>SuperMicro X8DTN+</td>
</tr>
<tr>
<td>Motherboard chipset</td>
<td>Intel 5520</td>
</tr>
<tr>
<td>BIOS name and version</td>
<td>American Megatrends Inc. (03/08/2010)</td>
</tr>
<tr>
<td>BIOS settings</td>
<td>Default</td>
</tr>
<tr>
<td><strong>Memory module(s)</strong></td>
<td></td>
</tr>
<tr>
<td>Total RAM in system (GB)</td>
<td>24</td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>Crucial CT51272BB1339.36SF D1</td>
</tr>
<tr>
<td>System</td>
<td>Super Micro 6026T-NTR+</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td>Type</td>
<td>PC3-10600</td>
</tr>
<tr>
<td>Speed (MHz)</td>
<td>1,333</td>
</tr>
<tr>
<td>Speed running in the system (MHz)</td>
<td>1,333</td>
</tr>
<tr>
<td>Timing/latency (tCL-tRCD-tRP-tRASmin)</td>
<td>9-9-9-24</td>
</tr>
<tr>
<td>Size (GB)</td>
<td>8</td>
</tr>
<tr>
<td>Number of RAM module(s)</td>
<td>6 x 8 GB</td>
</tr>
<tr>
<td>Chip organization</td>
<td>Double-sided</td>
</tr>
<tr>
<td>Rank</td>
<td>Dual</td>
</tr>
</tbody>
</table>

**Hard disk**

- Vendor and model number: Western Digital WD1601ABYS
- Number of disks in system: 2
- Size (GB): 160
- Buffer size (MB): 16
- RPM: 7,200 RPM
- Type: SATA

**Disk controller**

- Vendor and model: Intel Corporation ICH10R/DO SATA
- Controller cache: N/A
- Controller firmware: 1.2.5
- RAID configuration: RAID 0

**Operating system**

- Name: Citrix XenServer 5.6
- Build number: EXT3
- Service pack: 2.6.27.42-0.1.1.xs5.6.0.44.11158.xen
- File system: EXT3
- Kernel: Citrix XenServer 5.6
- Language: English

**Graphics**

- Vendor and model number: ATI ES1000
- Graphics memory: 32 MB
- Driver: ATI Technologies Inc. 8.240.50.3000 (1/21/2008)

**Ethernet**

- Vendor and model number: Intel 82576 Gigabit Dual Port Connection
- Type: Integrated
- Driver: 11.0.5.22 (4/6/2009)
<table>
<thead>
<tr>
<th>System</th>
<th>Super Micro 6026T-NTR+</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optical drive(s)</td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>TEAC DV28S-V</td>
</tr>
<tr>
<td>Type</td>
<td>DVD/CD-ROM</td>
</tr>
<tr>
<td>USB ports</td>
<td></td>
</tr>
<tr>
<td>Number</td>
<td>4</td>
</tr>
<tr>
<td>Type</td>
<td>2.0</td>
</tr>
</tbody>
</table>

*Figure 7: Test server configuration details.*
APPENDIX B – CLIENT CONFIGURATION INFORMATION

Figures 8 and 9 present detailed system configuration information for the four test clients.

<table>
<thead>
<tr>
<th>System</th>
<th>HP EliteBook 8440p (Intel Core i5 vPro processor-based notebook)</th>
<th>HP Mini 5102 (Intel Atom processor-based netbook)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number of processor packages</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>Number of cores per processor</td>
<td>2</td>
<td>1</td>
</tr>
<tr>
<td>Number of hardware threads per core</td>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>System power management policy</td>
<td>Balanced</td>
<td>Balanced</td>
</tr>
<tr>
<td>Processor power-saving option</td>
<td>Enhanced Intel SpeedStep® Technology</td>
<td>Enhanced Intel SpeedStep Technology</td>
</tr>
<tr>
<td>System dimensions (length x width x height)</td>
<td>13-3/16” x 9-1/8” x 1-3/8”</td>
<td>10-5/16” x 7-1/16” x 1-1/16”</td>
</tr>
<tr>
<td>System weight</td>
<td>5 lbs. 2.5 oz.</td>
<td>2 lbs. 7.5 oz.</td>
</tr>
<tr>
<td><strong>CPU</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vendor</td>
<td>Intel</td>
<td>Intel</td>
</tr>
<tr>
<td>Name</td>
<td>Core™ i5</td>
<td>Atom™</td>
</tr>
<tr>
<td>Model number</td>
<td>520M</td>
<td>N450</td>
</tr>
<tr>
<td>Stepping</td>
<td>C2</td>
<td>B0</td>
</tr>
<tr>
<td>Socket type and number of pins</td>
<td>BGA1288</td>
<td>FCBGA559</td>
</tr>
<tr>
<td>Core frequency (GHz)</td>
<td>2.40</td>
<td>1.66</td>
</tr>
<tr>
<td>Bus frequency</td>
<td>2.5 GT/s</td>
<td>667 MHz</td>
</tr>
<tr>
<td>L1 cache</td>
<td>64 KB + 64 KB (per core)</td>
<td>24 KB + 32 KB</td>
</tr>
<tr>
<td>L2 cache</td>
<td>512 KB (shared)</td>
<td>512 KB</td>
</tr>
<tr>
<td>L3 cache (MB)</td>
<td>3</td>
<td>N/A</td>
</tr>
<tr>
<td><strong>Platform</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vendor</td>
<td>HP</td>
<td>HP</td>
</tr>
<tr>
<td>Motherboard model number</td>
<td>172A</td>
<td>3653</td>
</tr>
<tr>
<td>Motherboard chipset</td>
<td>Intel QM57</td>
<td>Intel NM10</td>
</tr>
<tr>
<td>BIOS name and version</td>
<td>HP 68CCU Ver. F.06 (03/22/2010)</td>
<td>HP 68PGU Ver. F.03 (01/27/2010)</td>
</tr>
<tr>
<td><strong>Memory module(s)</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>Samsung M471B5673EH1-CH9</td>
<td>Hynix HYMP112S64CP6-S6</td>
</tr>
<tr>
<td>Type</td>
<td>PC3-10600S</td>
<td>PC2-6400S</td>
</tr>
<tr>
<td>Speed (MHz)</td>
<td>1,333</td>
<td>800</td>
</tr>
<tr>
<td>Speed running in the system (MHz)</td>
<td>1,066</td>
<td>800</td>
</tr>
<tr>
<td>Timing/Latency (tCL-tRCD-tRP-tRASmin)</td>
<td>7-7-7-20</td>
<td>5-5-5-15</td>
</tr>
</tbody>
</table>
## System

<table>
<thead>
<tr>
<th></th>
<th>HP EliteBook 8440p (Intel Core i5 vPro processor-based notebook)</th>
<th>HP Mini 5102 (Intel Atom processor-based netbook)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size (MB)</td>
<td>2,048</td>
<td>1,024</td>
</tr>
<tr>
<td>Number of memory module(s)</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>Chip organization (single-sided/double-sided)</td>
<td>Double-sided</td>
<td>Double-sided</td>
</tr>
<tr>
<td>Channel (single/dual)</td>
<td>Single</td>
<td>Single</td>
</tr>
</tbody>
</table>

## Hard disk

<table>
<thead>
<tr>
<th></th>
<th>Seagate ST9250410AS</th>
<th>Hitachi HTS725016A9A364</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of disks in system</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>Size (GB)</td>
<td>250</td>
<td>160</td>
</tr>
<tr>
<td>Buffer size (MB)</td>
<td>16</td>
<td>16</td>
</tr>
<tr>
<td>RPM</td>
<td>7,200</td>
<td>7,200</td>
</tr>
<tr>
<td>Type</td>
<td>SATA</td>
<td>SATA</td>
</tr>
<tr>
<td>Controller</td>
<td>Intel PCHM SATA AHCI Controller 6 Port</td>
<td>Standard AHCI 1.0 Serial ATA Controller</td>
</tr>
</tbody>
</table>

## Operating system

<table>
<thead>
<tr>
<th></th>
<th>Windows 7 Professional 32-bit</th>
<th>Windows 7 Professional 32-bit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Build number</td>
<td>7600</td>
<td>7600</td>
</tr>
<tr>
<td>Service Pack</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>File system</td>
<td>NTFS</td>
<td>NTFS</td>
</tr>
<tr>
<td>Kernel</td>
<td>ACPI x86-based PC</td>
<td>ACPI x86-based PC</td>
</tr>
<tr>
<td>Language</td>
<td>English</td>
<td>English</td>
</tr>
<tr>
<td>Microsoft DirectX version</td>
<td>11</td>
<td>11</td>
</tr>
</tbody>
</table>

## Graphics

<table>
<thead>
<tr>
<th></th>
<th>Intel Graphics Media Accelerator HD</th>
<th>Intel Graphics Media Accelerator 3150</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Integrated</td>
<td>Integrated</td>
</tr>
<tr>
<td>Chipset</td>
<td>Intel GMA HD</td>
<td>Intel GMA 3150</td>
</tr>
<tr>
<td>BIOS version</td>
<td>1994.0</td>
<td>1921.0</td>
</tr>
<tr>
<td>Total available graphics memory (MB)</td>
<td>762</td>
<td>248</td>
</tr>
<tr>
<td>Dedicated video memory (MB)</td>
<td>64</td>
<td>0</td>
</tr>
<tr>
<td>System video memory (MB)</td>
<td>0</td>
<td>64</td>
</tr>
<tr>
<td>Shared system memory (MB)</td>
<td>698</td>
<td>184</td>
</tr>
<tr>
<td>Resolution</td>
<td>1,366 x 768 x 32-bit</td>
<td>1,024 x 600 x 32-bit</td>
</tr>
</tbody>
</table>
### System

<table>
<thead>
<tr>
<th></th>
<th>HP EliteBook 8440p (Intel Core i5 vPro processor-based notebook)</th>
<th>HP Mini 5102 (Intel Atom processor-based netbook)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sound card/subsystem</td>
<td>IDT High Definition Audio CODEC</td>
<td>IDT High Definition Audio CODEC</td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>Intel 82577LM Gigabit Network Connection</td>
<td>Marvell Yukon 88E8059 PCI-E Gigabit Ethernet Controller</td>
</tr>
<tr>
<td>Driver</td>
<td>IDT 6.10.6257.0 (11/18/2009)</td>
<td>IDT 6.10.6257.0 (11/18/2009)</td>
</tr>
<tr>
<td>Ethernet</td>
<td>Intel 11.5.4.0 (11/05/2009)</td>
<td>Marvell 11.25.3.3 (04/26/2010)</td>
</tr>
<tr>
<td>Wireless</td>
<td>Intel Centrino® Advanced-N 6200 AGN</td>
<td>Broadcom® 43224AG 802.11a/b/g/draft-n Wi-Fi Adapter</td>
</tr>
<tr>
<td>USB ports</td>
<td>Intel 13.0.0.107 (09/15/2009)</td>
<td>Broadcom 5.60.350.11 (05/07/2010)</td>
</tr>
<tr>
<td>Number</td>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>Type</td>
<td>2.0</td>
<td>2.0</td>
</tr>
<tr>
<td>Other</td>
<td>eSATA, dual-mode DisplayPort, SD-MMC Card Reader</td>
<td>SD-MMC Card Reader</td>
</tr>
<tr>
<td>IEEE 1394 ports</td>
<td>1</td>
<td>N/A</td>
</tr>
<tr>
<td>Monitor</td>
<td>LED-backlit HD anti-glare</td>
<td>LED-backlit WSVGA widescreen</td>
</tr>
<tr>
<td>LCD type</td>
<td>14.0</td>
<td>10.1</td>
</tr>
<tr>
<td>Screen size (inches)</td>
<td>60</td>
<td>60</td>
</tr>
<tr>
<td>Battery</td>
<td>HP TD06</td>
<td>HP GC04</td>
</tr>
<tr>
<td>Size (length x width x height)</td>
<td>8” x 1-9/16” x 3/4&quot;</td>
<td>8-1/8” x 1-5/8” x 1/2”</td>
</tr>
<tr>
<td>Rated capacity</td>
<td>4600 mAh / 10.8 V (55 Wh)</td>
<td>8600 mAh / 14.8 V (128 Wh)</td>
</tr>
<tr>
<td>Weight (ounces)</td>
<td>11.2</td>
<td>7.0</td>
</tr>
</tbody>
</table>

Figure 8: Configuration details for the HP test clients.
<table>
<thead>
<tr>
<th>System</th>
<th>Wyse C90LEW (VIA Eden processor-based thin client)</th>
<th>Wyse Xenith (VIA Eden processor-based zero client)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number of processor packages</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td><strong>CPU</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vendor</td>
<td>VIA</td>
<td>VIA</td>
</tr>
<tr>
<td>Name</td>
<td>Eden</td>
<td>Eden</td>
</tr>
<tr>
<td>Stepping</td>
<td>C5R</td>
<td>N/A</td>
</tr>
<tr>
<td>Socket type</td>
<td>nanoBGA2</td>
<td>nanoBGA</td>
</tr>
<tr>
<td>Core frequency (GHz)</td>
<td>1.00</td>
<td>1.00</td>
</tr>
<tr>
<td>Bus frequency</td>
<td>400 MHz</td>
<td>133 MHz</td>
</tr>
<tr>
<td><strong>Platform</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vendor</td>
<td>Wyse</td>
<td>Wyse</td>
</tr>
<tr>
<td>Motherboard model number</td>
<td>Inventec C Class</td>
<td>Xenith C00X</td>
</tr>
<tr>
<td>Motherboard chipset</td>
<td>VIA VX855/VX875</td>
<td>VIA VX855</td>
</tr>
<tr>
<td>BIOS name and version</td>
<td>Phoenix Technologies 1.0B 10/07/2010</td>
<td>N/A</td>
</tr>
<tr>
<td><strong>Memory module(s)</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>Apacer 8Y.4D014.7254B</td>
<td>Apacer 8Y.40014.7254B</td>
</tr>
<tr>
<td>Type</td>
<td>Flash</td>
<td>Flash</td>
</tr>
<tr>
<td>Size (MB)</td>
<td>2,048</td>
<td>128</td>
</tr>
<tr>
<td><strong>Memory module(s) 2</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>Apacer 75.073AM.G06</td>
<td>Apacer 75.963AM.G04</td>
</tr>
<tr>
<td>Type</td>
<td>PC2-6400</td>
<td>PC2-6400</td>
</tr>
<tr>
<td>Speed (MHz)</td>
<td>800</td>
<td>800</td>
</tr>
<tr>
<td>Speed running in the system (MHz)</td>
<td>800</td>
<td>800</td>
</tr>
<tr>
<td>Size (MB)</td>
<td>1,024</td>
<td>512</td>
</tr>
<tr>
<td>Number of memory module(s)</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>Chip organization</td>
<td>Double-sided</td>
<td>Double-sided</td>
</tr>
<tr>
<td>Channel</td>
<td>Single</td>
<td>Single</td>
</tr>
<tr>
<td><strong>Operating System</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Microsoft Windows® XP Embedded</td>
<td>N/A</td>
</tr>
<tr>
<td>Build number</td>
<td>2600</td>
<td>N/A</td>
</tr>
<tr>
<td>Service Pack</td>
<td>3</td>
<td>N/A</td>
</tr>
<tr>
<td>File System</td>
<td>NTFS</td>
<td>N/A</td>
</tr>
<tr>
<td>Kernel</td>
<td>ACPI Uniprocessor PC</td>
<td>N/A</td>
</tr>
<tr>
<td>Language</td>
<td>English</td>
<td>N/A</td>
</tr>
<tr>
<td>Microsoft DirectX version</td>
<td>9.0c</td>
<td>N/A</td>
</tr>
</tbody>
</table>

Citrix XenDesktop: User experience across different client architectures
## Configuration Details for the Wyse Test Clients

<table>
<thead>
<tr>
<th>System</th>
<th>Wyse C90LEW (VIA Eden processor-based thin client)</th>
<th>Wyse Xenith (VIA Eden processor-based zero client)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>VIA Technologies VIA Chrome9 HCM IGP</td>
<td>VIA VX855</td>
</tr>
<tr>
<td>Type</td>
<td>Integrated</td>
<td>Integrated</td>
</tr>
<tr>
<td>Chipset</td>
<td>VIA Chrome9 HCM IGP</td>
<td>VIA VX855</td>
</tr>
<tr>
<td><strong>Sound card/subsystem</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>VIA Technologies High Definition Audio v 1.0</td>
<td>VIA VT1702S HD Audio</td>
</tr>
<tr>
<td><strong>Ethernet</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>VIA Velocity Family Gigabit</td>
<td>VIA Cicada SimpliPHY VT6122</td>
</tr>
<tr>
<td><strong>USB ports</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>Type</td>
<td>2.0</td>
<td>2.0</td>
</tr>
</tbody>
</table>

*Figure 9: Configuration details for the Wyse test clients.*
APPENDIX C – TEST METHODOLOGY

Setting up the infrastructure server

Installing Windows Server 2008 R2 Enterprise Edition

1. Boot the infrastructure server, and insert the Windows Server 2008 R2 installation DVD in the DVD-ROM drive.
2. At the Language Selection Screen, click Next.
3. Click Install Now.
4. Select Windows Server 2008 Enterprise Edition R2 (Full Installation), and click Next.
5. Click the I accept the license terms check box, and click Next.
6. Click Custom.
7. Click Drive options (advanced).
8. Ensure you select the proper drive, and click New.
9. Click Apply.
10. Click Next.
11. When the installation completes, open Server Manager → Configuration → Local Users and Computers → Users, select Administrator, and right click the Administrator. Set Password to Password1
12. Log out, and log in as Administrator.
13. Open Server Manager.
15. In the systems properties dialog box, rename the computer name to DC1
16. Reboot the system.
17. Set the password to Password1
18. At the Your password has been changed screen, click OK.

Installing system updates in Windows Server 2008 R2

Using the Windows Update feature, we installed the following updates:

- Security Update for Microsoft .NET Framework 3.5.1, Windows 7, and Windows Server 2008 R2 for x64-based Systems (KB2416471)
- Update for Internet Explorer 8 for Windows Server 2008 R2 x64 Edition (KB2398632)
- Security Update for Windows Server 2008 R2 x64 Edition (KB2347290)
- Security Update for Windows Server 2008 R2 x64 Edition (KB981550)
- Security Update for .NET Framework 3.5.1 on Windows 7 and Windows Server 2008 R2 for x64-based Systems (KB983590)
- Security Update for Windows Server 2008 R2 x64 Edition (KB2160329)
- Security Update for Windows Server 2008 R2 x64 Edition (KB2079403)
- Cumulative Security Update for Internet Explorer 8 for Windows Server 2008 R2 x64 Edition (KB2183461)
- Security Update for Windows Server 2008 R2 x64 Edition (KB978886)
- Security Update for Windows Server 2008 R2 x64 Edition (KB981852)
• Windows Malicious Software Removal Tool x64 - September 2010 (KB890830)
• Update for Windows Server 2008 R2 x64 Edition (KB2158563)
• Security Update for Windows Server 2008 R2 x64 Edition (KB982799)
• Security Update for Windows Server 2008 R2 x64 Edition (KB980436)
• Security Update for Windows Server 2008 R2 x64 Edition (KB982214)
• Security Update for Windows Server 2008 R2 x64 Edition (KB2286198)
• Windows Malicious Software Removal Tool x64 - July 2010 (KB8890830)
• Security Update for Windows Server 2008 R2 x64 Edition (KB2032276)
• Rules Update for Active Directory Domain Services Best Practice Analyzer for Windows Server 2008 R2 x64 Editions (KB980360)
• Microsoft .NET Framework 3.5 SP1 Update for Windows 7 and Windows Server 2008 R2 for x64-based Systems (KB982526)
• Security Update for Windows Server 2008 R2 x64 Edition (KB977894)
• Cumulative Security Update for ActiveX Killbits for Windows Server 2008 R2 x64 Edition (KB980195)
• Cumulative Security Update for Internet Explorer 8 for Windows Server 2008 R2 x64 Edition (KB982381)
• Update for Windows Server 2008 R2 x64 Edition (KB977074)
• Security Update for Windows Server 2008 R2 x64 Edition (KB979309)
• Security Update for Windows Server 2008 R2 x64 Edition (KB972270)
• Security Update for Windows Server 2008 R2 x64 Edition (KB980232)
• Security Update for Windows Server 2008 R2 x64 Edition (KB979683)
• Update for Windows Server 2008 R2 x64 Edition (KB976662)
• Windows Malicious Software Removal Tool x64 - June 2010 (KB890830)
• Security Update for Windows Server 2008 R2 x64 Edition (KB974571)
• Security Update for Windows Server 2008 R2 x64 Edition (KB979482)
• Security Update for Windows Server 2008 R2 x64 Edition (KB979559)
• Update for Best Practices Analyzer for Application Server for Windows Server 2008 R2 x64 Edition (KB981392)
• Update for Best Practices Analyzer for File Services for Windows Server 2008 R2 x64 Edition (KB981111)
• Security Update for Windows Server 2008 R2 x64 Edition (KB975560)
• Microsoft .NET Framework 3.5 SP1 Security Update for Windows 7 and Windows Server 2008 R2 for x64-based Systems (KB979916)
• Update for Best Practices Analyzer for HYPER-V for Windows Server 2008 R2 x64 Edition (KB977238)
• Security Update for Windows Server 2008 R2 x64 Edition (KB971468)
• Microsoft .NET Framework 3.5 SP1 Update for Windows 7 and Windows Server 2008 R2 for x64-based Systems (KB982526)
• Update for Windows Server 2008 R2 x64 Edition (KB981793)
• Update for Best Practices Analyzer for DHCP Server for Windows Server 2008 R2 x64 Edition (KB977236)
Setting up network configuration on DC1

1. Click Start ➔ Run, and type ncpa.cpl
2. Right-click on the active adaptor, and click Properties.
4. At the Internet Protocol Version 4 (TCP/IPv4) Properties screen, select the Use the following IP address radio button.
5. Type 192.168.1.111 for the IP address, 255.255.255.0 for the default subnet mask, and 192.168.1.200 for preferred DNS server.
6. Click OK, and click Close to exit.

Installing Active Directory and DNS services on DC1

To install Active Directory, complete the following steps:
1. Click Start ➔ Run, type dcpromo and click OK.
2. At the Active Directory Domain Services Installation Wizard welcome screen, check the Use advanced mode installation option, and click Next.
3. In the Choose a Deployment Configuration dialog box, select Create a new domain in a new forest, and click Next.
4. At the FQDN page, type login-vsi.com and click Next.
5. At the NetBIOS name prompt, leave the name LOGIN-VSI, and click Next.
6. At the Forest Functionality level, select Windows Server 2008 R2, click Next.
7. At the additional Domain Controller Options, leave DNS server selected, and click Next.
8. At the System Folder Location screen, leave the default options, and click Next.
Assign a Directory Services Restore Mode Administrator account password, and click Next.

At the Summary screen, review your selections, and click Next.

Once Active Directory Domain Services finishes installing, click Finish, and restart the system.

When DC1 restarts, log in as login-vsi\administrator.

Click Start → Run, and type dsa.msc to open Active Directory Users and Computers.

In the left pane, open Active Directory Users and Computers, and right-click the Login-vsi icon. Select New → Organization Unit.

In the new Object → Organizational Unit Name field, type XendDesktop, and click OK.

Close Active Directory Users and Computers.

Creating a static entry in DNS for Xenserver-1 on DC1

Click Start → Administrative tools → DNS manager.

Click DNS → DC1 → login-vsi.com.

Right-click, and select New A record.

Type Xenserver-1 for host name, and 192.168.1.230 for the address.

Select Create an associated pointer (PTR) record.

Close DNS.

Verify the record by opening a command prompt (Click Start → Run, type cmd and press Enter).

In the command window, type ping xenserver-1 and press Enter.

Setting up DHCP services on DC1

Click Start → Administrative Tools → Server Manager → Add Roles.

Select DHCP Server, and click Next.

At the Introduction to DHCP Server screen, click Next.

At the Specify IPv4 DNS Settings screen, type loginvsi.com for the parent domain.

Set the preferred DNS server IPv4 address to 192.168.1.200 and click Next.

At the Specify IPv4 WINS Server Settings screen, select WINS is not required for applications on the network, and click Next.

At the Add or Edit DHCP Scopes screen, click Add.

At the Add Scope screen, enter the Name DHCP Scope name.

In the next box, set the following values, and click OK.

- Starting IP Address: 192.168.1.1
- Ending IP Address: 192.168.1.199
- Subnet mask: 255.255.255.0

Check the Activate This Scope box.

At the Add or Edit DHCP Scopes screen, click Next.

Click the Enable DHCP v6 Stateless Mode radio button, and click Next.

Leave the default IPv6 DNS Settings, and click Next.

At the Authorize DHCP server dialog box, select Use current credentials.

At the Confirm Installation Selections screen, click Next. If the installation is set up correctly, a screen displays saying that DHCP server install succeeded.

Click Close.
Enabling the Hyper-V role on DC1
1. Click Start → Administrative Tools → Server Manager.
2. Click Roles.
3. Click Add Roles, and click Next.
4. Select the Hyper-V role by checking the box beside it, and click Next.
5. Check the box beside the Ethernet Card you wish to use for client/server traffic, and click Next.
6. Click Install to begin the Hyper-V installation.
7. When the installation finishes, click Close.
8. When the installer prompts you to restart now, click Yes.
9. Follow the prompt to log onto the system.
10. Enter the password, and click the arrow to continue. The Resuming Configuration Wizard should start automatically.
11. Once the Resuming Configuration Wizard completes, the installation results appear with a message that the installation succeeded.
12. Click Close.

Configuring virtual networks on DC1
1. Open Hyper-V Manager.
2. From the Actions menu, click Virtual Network Manager.
3. Under Create virtual network, select External network. Use one physical NIC that is connected to the private 192.168.0.x network. Click Add, and the New Virtual Network page appears.
4. For the new network, type the name VSI-net
5. Review the other properties and modify them if necessary.
6. Click OK to create the virtual network and close Virtual Network Manager, or click Apply to create the virtual network and continue using Virtual Network Manager.
7. Repeat steps 1 through 6 and create a public network on the Internet-accessible interface.

Setting up an ISO repository for install media
1. Click Start → Computer → c:\
2. Right-click, and select New folder.
3. Type ISO and click Enter.
5. Click the Sharing tab.
6. Click Share...
7. In the dialog box, type everyone and click Add.
8. Click Share.
9. Click Done.
10. Copy a Windows 7 Enterprise Edition iso file to c: \ iso. This will be needed for creating Windows 7 VMs on XenServer.
Setting up the server under test

Installing XenServer 5.6

Note that XenServer is effectively an operating system, and installing it removes any existing operating system from a server.

1. Insert the XenServer 5.6 installation disc, and follow the instructions on the installation wizard.
2. At the Select Keymap screen, choose your key map or accept the default of QWERTY US, and press Enter.
3. At the Welcome to XenServer screen, accept the default values.
4. Select Install or upgrade XenServer Host, and press Enter.
5. At the Welcome to XenServer Setup screen, read the warning, and press Enter.
6. If you had installed an earlier version of XenServer, select Perform clean installation on the Installation Type page, and press Enter. Be aware that doing this will cause XenServer to remove any existing VMs stored on the server.
8. If the computer you are installing XenServer on has multiple local hard disk drives, the Select Primary Disk screen will appear. If the computer has only one hard disk drive, this screen will not appear.
9. Select the primary disk (where you will install XenServer), and press Enter.
10. At the Choose a drive to be formatted for use by XenServer for VM storage pop-up, press Enter.
11. At the Select Installation Source screen, press Enter to accept the default setting, which is Local media.
12. At the Linux Pack screen, select No, and press Enter.
13. At the Verify Installation Source screen, press Enter to accept the default setting, which is Verify installation source. This process may take some time. If you receive a verification error message, download the software again and restart the installation process.
14. At the Verification Successful screen, press Enter.
15. At the Set Password screen, enter a root password, enter it again to confirm it, and press Enter.
16. At the Networking screen, the application may prompt you to select a management network interface if your computer has multiple network interface cards (NICs). If so, select a NIC, and press Enter. If your computer has a single NIC, the application selects this NIC.
17. Select Static configuration, specify the following values:
   - **IP Address:** 192.168.1.230
   - **Subnet mask:** 255.255.255.0
18. Press Enter.
19. At the Hostname and DNS Configuration screen, specify the name of the server you are installing:
   - At the Hostname Configuration section, select Manually specify.
   - **Type the name xenserver-1**
   - At the DNS Configuration section, select Manually specify.
   - **Type 192.168.1.200 for the IP address of DNS server 1, and press Enter.**
20. At the Select Time Zone screen, select your geographical area, and press Enter. Then, select a specific locale in your time zone, and press Enter.
21. At the System Time screen, select use NTP time server, type 192.168.1.200, and press Enter.
22. At the Confirm Installation screen, select Install XenServer, and press Enter.
23. At the Set Local Time screen, type the correct date and time, and press Enter.
24. At the Installation Complete screen, press Enter. The system will automatically restart.
25. When the server reboots, log in as root.
26. At the command line, type nano etc/hosts
27. Type 192.168.1.230 xenserver-1 xenserver-1.login.vsi.com
28. Type ALT–X and save the new /etc/hosts file.
29. Log off the console.

Installing the Desktop Delivery Controller

Creating a Windows 2003 R2 Enterprise Edition (x86) Hyper-V virtual machine, xen-ddc
1. Log onto DC1.
2. Open Hyper-V Manager, and Click Start→Administrative Tools→Hyper-V Manager.
3. In the left pane, select DC1, right-click and select New Virtual Machine.
4. In the Specify Name and Location screen, name the new virtual machine xen-ddc, select the V:/drive as the location for storage, and click Next.
5. In the Assign memory screen, select 4096 MB for memory, and click Next.
6. In the Configure networking screen, select the public network for Network being used, and click Next.
7. Connect virtual hard drive.
8. In the Installation Options screen, select the appropriate media for Windows 2003 Enterprise Edition R2 (x86) disk 1, and click Next.
9. Click Finish.
10. When completed, right-click the newly created xen-ddc in the virtual machine window and select Settings.
11. Select Processor, change from 1 to 2 processors, and click OK.

Installing Windows 2003 Enterprise Edition (x86) on the virtual machine xen-ddc
1. Start the Virtual machine xen-ddc, and open a console.
3. Press Enter to begin.
4. Read and accept the licensing agreement, and press F8 if you accept it.
5. Select the 40GB partition to install Windows Server 2003 on.
6. Select format in NTFS quick. Setup begins copying necessary files from the installation.
7. The machine will reboot and loads a GUI mode phase.
8. Change your regional settings to accommodate your location, language, and time zone.
9. Enter your name and organization, and click Next.
10. Enter the appropriate license, and click Next.
11. Type the computer name xen-ddc and password Password
12. Select the date, time, and time zone settings. Setup installs the networking components.
13. Continue with default network settings.
14. The setup process finishes copying files and configuring the setup.
16. Log in as Administrator.
17. Windows Setup will require Windows 2003 Enterprise Edition (x86) R2 CD2 to complete the installation; insert CD 2 when it prompts you, and click OK.
18. At the Welcome screen, click Next.
19. Accept the End-user License Agreement, and click Next.
20. Setup copies files and completes the installation.
21. Click Finish.
22. Close the Hyper-V manager.

**Configuring Windows 2003 Enterprise Edition (x86) on the virtual machine xen-ddc**

1. Log onto DC1.
2. Open Hyper-V Manager, and click Start → Administrative Tools → Hyper-V Manager.
3. In the virtual machine menu, right-click the xen-ddc virtual machine, and select Connect.
4. On the xen-ddc console menu, select Action → Insert Integration Services Setup Disk.
5. When integration services have been installed, select Yes to reboot.
6. After the system has rebooted, log in and click Start → Windows Update.
7. Select Express and install all available patches. We installed the following updates:
   - Security Update for Windows Server 2003 (KB981332)
   - Update for Windows Server 2003 (KB976662)
   - Update for Windows Server 2003 (KB971737)
   - Update for Windows Server 2003 (KB970430)
   - Security Update for Jscript 5.8 for Windows Server 2003 (KB971961)
   - Security Update for Windows Server 2003 (KB2286198)
   - Security Update for Windows Server 2003 (KB980436)
   - Security Update for Windows Server 2003 (KB2079403)
   - Security Update for Windows Server 2003 (KB982214)
   - Windows Malicious Software Removal Tool - August 2010 (KB890830)
   - Security Update for Windows Server 2003 (KB2115168)
   - Security Update for Windows Server 2003 (KB2160329)
   - Cumulative Security Update for Internet Explorer 6 for Windows Server 2003 (KB2183461)
   - Security Update for Windows Server 2003 (KB2229593)
   - Security Update for Windows Server 2003 (KB975562)
   - Microsoft .NET Framework 1.1 SP1 Security Update for Windows Server 2003 x86 and Windows Server 2003 R2 x86 (KB979907)
   - Security Update for Windows Server 2003 (KB979482)
   - Cumulative Security Update for ActiveX Killbits for Windows Server 2003 (KB980195)
   - Security Update for Windows Media Format Runtime 9.5 for Windows Server 2003 (KB978695)
   - Security Update for Windows Server 2003 (KB980218)
   - Update for Windows Server 2003 (KB981793)
   - Security Update for Windows Server 2003 (KB978542)
Citrix XenDesktop: User experience across different client architectures

- Security Update for Windows Server 2003 (KB978601)
- Security Update for Windows Server 2003 (KB979683)
- Security Update for Windows Server 2003 (KB978338)
- Security Update for Windows Server 2003 (KB979309)
- Security Update for Windows Server 2003 (KB981350)
- Security Update for Windows Server 2003 (KB977816)
- Security Update for Windows Server 2003 (KB980232)
- Security Update for Windows Server 2003 (KB978706)
- Security Update for Windows Server 2003 (KB977914)
- Security Update for Windows Server 2003 (KB975560)
- Security Update for Windows Server 2003 (KB978037)
- Security Update for Windows Server 2003 (KB975713)
- Security Update for Windows Server 2003 (KB972270)
- Security Update for Windows Server 2003 (KB973904)
- Update for Windows Server 2003 (KB955759)
- Security Update for Windows Server 2003 (KB974392)
- Security Update for Windows Server 2003 (KB974318)
- Update for Windows Server 2003 (KB968389)
- Microsoft .NET Framework 1.1 Service Pack 1 Security Update for Windows Server 2003 x86 and Windows Server 2003 R2 x86 (KB953298)
- Security Update for Windows Server 2003 (KB969059)
- Security Update for Windows Server 2003 (KB958869)
- Security Update for Windows Server 2003 (KB974112)
- Security Update for Windows Server 2003 (KB974571)
- Security Update for Windows Server 2003 (KB975025)
- Security Update for Windows Media Format Runtime 9.5 for Windows Server 2003 (KB954155)
- Security Update for Jscript 5.6 for Windows Server 2003 (KB971961)
- Security Update for Windows Server 2003 (KB967723)
- Security Update for Windows Server 2003 (KB956844)
- Internet Explorer 8 for Windows Server 2003
- Security Update for Windows Server 2003 (KB971657)
- Security Update for Windows Server 2003 (KB973815)
- Security Update for Windows Server 2003 (KB960859)
- Security Update for Windows Server 2003 (KB973507)
- Security Update for Windows Server 2003 (KB958469)
- Security Update for Windows Server 2003 (KB973869)
- Security Update for Windows Server 2003 (KB973540)
- Security Update for Windows Server 2003 (KB971032)
- Security Update for Windows Server 2003 (KB970238)
- Security Update for Windows Server 2003 (KB961501)
• Security Update for Windows Server 2003 (KB923561)
• Security Update for Windows Server 2003 (KB959426)
• Security Update for Windows Server 2003 (KB960803)
• Security Update for Windows Server 2003 (KB952004)
• Security Update for Windows Server 2003 (KB956572)
• Update for Windows Server 2003 (KB967715)
• Security Update for Windows Server 2003 (KB956803)
• Security Update for Windows Server 2003 (KB925902)
• Security Update for Windows Server 2003 (KB956802)
• Security Update for Windows Server 2003 (KB952069)
• Security Update for Windows Server 2003 (KB958644)
• Security Update for Windows Server 2003 (KB944338)
• Security Update for Windows Server 2003 (KB950974)
• Security Update for Windows Server 2003 (KB952954)
• Security Update for Windows Server 2003 (KB951748)
• Security Update for Windows Server 2003 (KB950762)
• Cumulative Security Update for ActiveX Killbits for Windows Server 2003 (KB950760)
• Security Update for Windows Server 2003 (KB945553)
• Update for Windows Server 2003 (KB948496)
• Security Update for Windows Server 2003 (KB943055)
• Security Update for Windows Server 2003 (KB946026)
• Security Update for Windows Server 2003 (KB941569)
• Security Update for Windows Server 2003 (KB944653)
• Update for Windows Server 2003 (KB936357)
• Security Update for Microsoft .NET Framework, Version 1.1 Service Pack 1 (KB933854)
• Security Update for Windows Server 2003 (KB938127)
• Security Update for Windows Server 2003 (KB926122)
• Security Update for Windows Media Player 6.4 (KB925398)
• Cumulative Security Update for Outlook Express for Windows Server 2003 (KB929123)
• Security Update for Windows Server 2003 (KB924667)
• Update for Windows Server 2003 (KB927891)
• Security Update for Windows Server 2003 (KB932168)
• Security Update for Windows Server 2003 (KB930178)

8. After reboot, go to the Hyper-V console menu, and click File ➔ Settings ➔ Network adaptor.
9. Change the current adaptor from the public network to the login-vsi network (private), and click OK.
10. Log into xen-ddc as Administrator.
11. Click Start ➔ Control Panel ➔ Network Connections, right-click Local Area Connection, and select Properties.
12. In the Local Area Connection Properties screen, select Internet Protocol (TCP/IP).
13. At the Internet Protocol Properties screen, complete these fields as follows:
• IP address: 192.168.1.231
• Subnet mask: 255.255.255.0
• Preferred DNS: 192.168.1.200

14. Click OK.
15. Go to Start, right-click My Computer, and select Properties.
16. In the System Properties box, select the Computer Name tab.
17. On the Computer Name tab, select Change.
18. To join the login-vsi domain, select Domain, specify login-vsi, and click OK.
19. When prompted for credentials, use the following, and select OK:
   • Username: login-vsi\administrator
   • Password: Password1
20. At the Welcome to the login-vsi domain screen, select OK.
21. Select OK again to exit the Computer Name window.
22. Select Yes to reboot the xen-ddc server to finish the domain join.

**Installing Desktop Delivery Controller**

Installing Desktop Delivery Controller automatically installs all the prerequisite Delivery Controller components. When installing Terminal Services and Internet Information Services (IIS), the installation program prompts you to insert the Windows Server 2003 installation disc when appropriate.

1. Log into the xen-ddc as a login-vsi\administrator.
2. Ensure that the VM has access to the XenDesktop Delivery Controller media.
3. From the Desktop Delivery Controller media, run autorun.exe on the installation disc.
4. At the Welcome screen of the Desktop Delivery Controller installer, select Install Server Components.
5. Read and accept the license agreement, and click Next.
6. At the Select Components screen, leave all the options selected, and click Next.
7. At the Create or Join a Farm screen, select Create new farm, specify XENFARM as the name, and click Next.
9. At the Optional Server Configuration screen, click Next.
10. At the Start Installation screen, do not specify a database server, click Next.
11. Follow the onscreen instructions. Note that when the installation program prompts you to restart the server, you must log as login-vsi\administrator to continue.
12. At the Setup Complete page, leave both checkboxes selected, and click Finish.
13. At all hardware installation notifications, select Continue anyway.
14. The system will restart again. Login into xen-ddc as login-vsi\administrator again.
15. Both the Active Directory Configuration Wizard and the License Management Console will start.
Configuring the Active Directory organizational unit

Use the Active Directory Configuration Wizard to configure the default population of the Active Directory organizational unit (OU) specifically for running Desktop Delivery Controller. The wizard begins automatically after you complete the previous procedure.

1. At the first screen of the Active Directory Configuration Wizard, click Next.
2. At the Configure Farm OU in Active Directory screen, click Browse, and navigate to the XenDesktop OU.
3. Click OK, and click Next.
4. At the Summary screen, click Finish and, once the application has applied the settings, click Close.
5. When the application prompts you to start the Delivery Services Console, click Yes. Leave the console running for the next procedure.

Installing the XenDesktop license

To use XenDesktop you must have a valid license or a valid evaluation license. To get a new 90-day evaluation license go to http://www.citrix.com/English/ss/downloads/index.asp?ntref=hp_nav_US to register and activate a XenDesktop license file.

1. Once you have the license file Log into xen-dcc as login-vsi\administrator.
2. Open the license manager, click Start→All programs→Citrix→Management Console→License Manager.
3. In the License Management Console, select the Configuration tab, and click Step 2: Copy license file to this license server.
4. At the Upload license file screen, click Browse, and navigate to the location of your XenDesktop license file.
5. To select the required license file, click Open.
6. To add the license file to the License Management Console, click Upload.
7. Close the License Management Console.
8. To start the License Management Console again, click Start→All Programs→Citrix→Management Consoles→License Management Console.

Configuring the Delivery Services Console

When the Delivery Services Console starts for the first time, the Configure and Run Discovery wizard starts automatically.

1. At the Welcome screen, click Next.
2. At the Select Product or Components screen, ensure that all the check boxes are selected, and click Next.
3. At the Select Controllers screen, click Add Local Computer, and click Next.
4. At the Preview Discovery screen, click Next.
5. Wait until discovery is complete, and click Finish. In the Delivery Services Console, the Desktop Delivery Controller VM (xen-dcc) is added to the left pane under Citrix Resources→Desktop Delivery Controller→XENFARM→Controllers→xen-dcc.
6. Close the Delivery Services Console.
7. If you wish to restart the Delivery Services Console, click Start → All Programs → Citrix → Management Consoles → Delivery Services Console.

**Installing XenCenter on xen-ddc**

1. Log into xen-ddc as login-vsi\administrator, open a Web browser, and connect to http://192.168.1.230.
2. Select XenCenter installer.
4. After the file downloads, select Run when prompted with the Windows security warning.
5. At the Welcome to the Citrix XenCenter Setup Wizard screen, click Next.
6. At the Custom Setup screen, accept the default features, and click Next.
7. At the Destination Folder screen, accept the default path of C:\Program Files\Citrix\XenCenter\.
8. Under the Install for tab, select All Users, and click Next.
9. At the Ready to install Citrix XenCenter screen, click Install.
10. When the installation completes, click Finish.

**Connecting and configuring Xenserver-1 via XenCenter**

1. Click Start → All Programs → Citrix XenCenter.
2. When XenCenter launches, it will ask if you want to check for new versions of XenCenter. Choose No.
3. In the left pane, select XenCenter and right-click, and select Add.
4. In the add New Server box, enter the following:
   - **Server name**: xenserver-1
   - **Username**: root
   - **Password**: Password1

**Installing a license to the XenServer**

1. Open Tools → License Manager.
2. Click Assign license.
3. In the Apply license box, apply these settings and select OK:
   - **License server**: Citrix XenServer for XenDesktop
   - **Name**: xen-dcc
   - **Port number**: 27000

**Connecting XenServer to the DC1 ISO repository**

1. Click xenserver-1.
2. In the right window, click the Storage tab.
3. Click New storage repository.
4. In the New storage repository wizard, click ISO library → Windows File Sharing (CIFS), and click Next.
5. Enter the following values, and click Finish:
   - **Name**: ISO
   - **Share name**: \dc1\ISO
   - **Username**: login-vsi\administrator
   - **Password**: Password1
Configuring the network
1. Click the NIC tab in XenCenter.
2. Verify that there are two NICs:
   - One should be connected to the 192.168.1.230 network
   - One should have Internet access
3. Click the Network tab.
4. To create the vsi-network, click Add Network...
5. In the new network box, select External Network, and click Next.
6. Type vsi-net for network, and click Next.
7. Select the NIC for the 192.168.1.230 network, and click Finish.
8. To create the public network, click Add Network...
9. In the new network box, select External Network, and click Next.
10. Type Public for network, and click Next.
11. Select the NIC for the Internet-accessible network.
12. Click Finish.

Installing the Windows 7 Enterprise (32 bit) Virtual Machine
1. Log into xen-dcc.
2. Open XenServer.
3. Right-click xenserver-1, and select New VM.
4. In the Select a VM template box, scroll to the bottom, select Other install media, and click Next.
5. In the Name the new virtual machine box, type win7ee and click Next.
6. In the Locate the operating system installation media box, select the Windows 7 Enterprise Edition x86.iso, and click Next.
7. In the Select a home server box, click xenserver-1, and click Next.
8. In the Allocate processor and memory resources box, select 2 vCPUs and 1024 MB and, click Next.
9. In the Configure storage for the new VM box, click Add...
10. In the Add virtual Disk box, type disk0 for name and 20480 MB for Size, and click Add.
11. In the Configure storage for the new VM, click Next.
12. In the Configure Networking box, ensure only the public network is present, delete any others, and click Next.
13. At the Ready to create the new virtual machine box, click Next.
14. The new VM called win7ee should appear on the left pane of XenServer. Click it, and click the Console tab.

Windows 7 guest: Begin Windows 7 Enterprise (x68) installation on the newly created VM
1. When the installation prompts you, press any key to begin setup.
2. Enter your language preferences, and click Next.
3. Click Install.
4. Accept the license terms, and click Next.
5. Select Custom, and select the drive that will contain the OS.
6. Click Install. Setup begins.
7. Type username **WIN7EE** and computer **WIN7EE-PC**, and click Next.
8. Enter no password, and click Next.
9. For system protection Use recommended settings, and click Next.
10. Enter time zone, and click Next.
11. Select the Work Network setting, and click Next.
12. Use Windows Update to patch the Windows 7 installation. We installed the following updates:
   - Security Update for Windows 7 (KB978886)
   - Security Update for .NET Framework 3.5.1 on Windows 7 x86 (KB983590)
   - Update for Windows 7 (KB975496)
   - Security Update for Windows 7 (KB975467)
   - Security Update for Windows 7 (KB978601)
   - Security Update for Windows 7 (KB2347290)
   - Update for Windows 7 (KB974332)
   - Microsoft .NET Framework 3.5 SP1 Update for Windows 7 x86 (KB982526)
   - Security Update for Windows 7 (KB982665)
   - Update for Windows 7 (KB977074)
   - Update for Windows 7 (KB2158563)
   - Cumulative Security Update for ActiveX Killbits for Windows 7 (KB980195)
   - Security Update for Windows 7 (KB974571)
   - Update for Windows 7 (KB980408)
   - Security Update for Windows 7 (KB982799)
   - Security Update for Windows 7 (KB978542)
   - Security Update for Windows 7 (KB2079403)
   - Definition Update for Windows Defender - KB915597 (Definition 1.91.1370.0)
   - Update for Windows 7 (KB980846)
   - Update for Windows 7 (KB2272691)
   - Update for Windows 7 (KB974431)
   - Security Update for Windows 7 (KB979482)
   - Security Update for Windows 7 (KB982214)
   - Cumulative Update for Media Center for Windows 7 (KB981078)
   - Update for Windows 7 (KB976662)
   - Security Update for Windows 7 (KB972270)
   - Security Update for Windows 7 (KB977165)
   - Security Update for Windows 7 (KB975560)
   - Security Update for Windows 7 (KB981852)
   - Cumulative Security Update for Internet Explorer 8 for Windows 7 (KB2183461)
   - Security Update for Windows 7 (KB2286198)
   - Windows Malicious Software Removal Tool - September 2010 (KB890830)
   - Security Update for Windows 7 (KB981332)
   - Update for Rights Management Services Client for Windows 7 (KB979099)
   - Security Update for Windows 7 (KB979309)
   - Update for Windows 7 (KB979538)
• Security Update for Windows 7 (KB980436)
• Security Update for Windows 7 (KB980232)
• Security Update for Windows 7 (KB2160329)
• Update for Internet Explorer 8 Compatibility View List for Windows 7 (KB2362765)
• Microsoft .NET Framework 3.5 SP1 Security Update for Windows 7 x86 (KB979916)
• Security Update for Windows 7 (KB980218)

**Windows 7 guest: Installing Xen tools**
1. In XenCenter, click the drop-down menu for DVD Drive 1:, and click xetools.iso.
2. When prompted, click Run xensetup.exe.
3. When The User Account Control notification prompts appears, click Yes.
4. Accept the license agreement, and click Next.
5. Accept the default installation location, and click Install.
6. Click Finish to reboot.
7. When win7ee reboots, it will detect new hardware and prompt you to reboot again. Click OK.

**Windows 7 guest: Turning off system restore**
1. Click Start, right-click Computer, click Properties→Advanced system settings→System Protection→Configure→Turn off system protection, and click OK.

**Windows 7 guest: Adjusting page file**
2. In Performance settings, select the Advanced tab, and select change for Virtual Memory.
4. Select Custom size, enter 2048 for both values, and select Set.

**Windows 7 guest: Joining the login-vsi domain**
1. Right-click Computer→Properties→Change settings→Computer name.
2. Select Change.
3. In the Member of section, select Domain.
4. Enter the domain name: login-vsi.com, and click OK.
5. Enter the domain admin account and password for the login-vsi domain.
6. Reboot.

**Windows 7 guest: Installing the XenDesktop agent**
1. From the Citrix XenDesktop media, run XDE400VDWX86SP1\xdsagent.msi.
2. When the Windows Security warning prompts you, click Run.
3. At the XenDesktop agent welcome screen, click Next.
4. Accept the license agreement, and click Next.
5. Accept the default port, 8080, and click Next.
6. Accept Firewall defaults, and click Next.
7. In Farm Selection, select XENDESKTOP, and click Next.
8. In the Ready to install box, click Install.
9. When the installation completes, click Finish.
10. Click Yes to reboot the system.
Creating a XenDesktop group

1. Log into xen-ddc as login-vsi\administrator.
2. Click Start→All Programs→Citrix→Management Consoles→Delivery Services Console.
3. Go to Citrix Delivery Services Console→Citrix Resources→Desktop Delivery Controller→XENDESKTOP.
4. Right-click Desktop Delivery Services Console and click All Tasks→Create Desktop Group.
5. In the Welcome screen for Create Desktop Group, click Next.
6. Select Assigned, and click Assign on first use. Click Next.
7. For hosting infrastructure, choose Citrix Xen VM infrastructure (included with XenDesktop).
8. To specify the hosting infrastructure, enter the following values, and click Next:
   - Address: http://xenserver-1
   - User name: root
   - Password: Password1
9. In the Select Virtual Desktops box, select Add.
10. In the Select Virtual Machine box, and click OK.
11. Verify that the Active Directory computer account is correct, and click Next.
12. To add users, click Add.
13. In the Users and Groups box, type domain users; domain admins, and click OK.
14. The two groups should be present in the users box, click Next.
15. For display name, type XenDesktop-pool and click Next.
16. Keep the Default icon, and click Next.
17. Do not select either check box in the publishing options box, and click Finish create the desktop group.
18. Click Citrix Delivery Services Console→Citrix Resources→Desktop Delivery Controller→XENDESKTOP→Desktop Groups→XenDesktop pool.
19. In the Virtual desktops screen, verify that win7-pc.login-vsi.com is registered and its status is idle.
20. Close the Desktop Delivery Controller console, and log out.
APPENDIX D – CPU UTILIZATION AND THROUGHPUT DATA

Figures 10 through 13 present the average CPU utilization percentage and transfers/second data for each client across the four workloads. As we note earlier, we were unable to record data from the Wyse Xenith zero client because the system is unable to host an operating system.

<table>
<thead>
<tr>
<th>720p video playback</th>
<th>CPU %</th>
<th>Transfers/second</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Server</td>
<td>Client</td>
</tr>
<tr>
<td>HP EliteBook 8440p</td>
<td>1.11</td>
<td>14.56</td>
</tr>
<tr>
<td>HP Mini 5102</td>
<td>1.18</td>
<td>59.09</td>
</tr>
<tr>
<td>Wyse C90LEW</td>
<td>1.09</td>
<td>96.23</td>
</tr>
<tr>
<td>Wyse Xenith</td>
<td>1.02</td>
<td>N/A</td>
</tr>
</tbody>
</table>

Figure 10: CPU percent average and transfers/second for the server and clients during the 720p video playback test.

<table>
<thead>
<tr>
<th>1080p video playback</th>
<th>CPU %</th>
<th>Transfers/second</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Server</td>
<td>Client</td>
</tr>
<tr>
<td>HP EliteBook 8440p</td>
<td>1.21</td>
<td>16.75</td>
</tr>
<tr>
<td>HP Mini 5102</td>
<td>1.29</td>
<td>66.99</td>
</tr>
<tr>
<td>Wyse C90LEW</td>
<td>1.12</td>
<td>98.59</td>
</tr>
<tr>
<td>Wyse Xenith</td>
<td>1.23</td>
<td>N/A</td>
</tr>
</tbody>
</table>

Figure 11: CPU percent average and transfers/second for the server and clients during the 1080p video playback test.

<table>
<thead>
<tr>
<th>1080p video playback + print job</th>
<th>CPU %</th>
<th>Transfers/second</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Server</td>
<td>Client</td>
</tr>
<tr>
<td>HP EliteBook 8440p</td>
<td>1.81</td>
<td>38.56</td>
</tr>
<tr>
<td>HP Mini 5102</td>
<td>2.49</td>
<td>86.96</td>
</tr>
<tr>
<td>Wyse C90LEW</td>
<td>2.62</td>
<td>98.65</td>
</tr>
<tr>
<td>Wyse Xenith</td>
<td>2.73</td>
<td>N/A</td>
</tr>
</tbody>
</table>

Figure 12: CPU percent average and transfers/second for the server and clients during the 1080p video playback and print job test.

In Figure 13, note that, because the Wyse C90LEW thin client is unable to redirect Flash content, while playing this type of media, the server renders all the content and sends it to the thin client. This type of rendering greatly increases server CPU usage as well as server bandwidth utilization.
## Flash video playback

<table>
<thead>
<tr>
<th>Flash video playback</th>
<th>CPU %</th>
<th>Transfers/second</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Server</td>
<td>Client</td>
</tr>
<tr>
<td>HP EliteBook 8440p</td>
<td>0.25</td>
<td>7.16</td>
</tr>
<tr>
<td>HP Mini 5102</td>
<td>0.25</td>
<td>65.50</td>
</tr>
<tr>
<td>Wyse C90LEW</td>
<td>2.47</td>
<td>61.50</td>
</tr>
<tr>
<td>Wyse Xenith</td>
<td>2.36</td>
<td>N/A</td>
</tr>
</tbody>
</table>

*Figure 13: CPU percent average and transfers/second for the server and clients during the Flash video playback test.*
We provide industry-leading technology assessment and fact-based marketing services. We bring to every assignment extensive experience with and expertise in all aspects of technology testing and analysis, from researching new technologies, to developing new methodologies, to testing with existing and new tools.

When the assessment is complete, we know how to present the results to a broad range of target audiences. We provide our clients with the materials they need, from market-focused data to use in their own collateral to custom sales aids, such as test reports, performance assessments, and white papers. Every document reflects the results of our trusted independent analysis.

We provide customized services that focus on our clients’ individual requirements. Whether the technology involves hardware, software, Web sites, or services, we offer the experience, expertise, and tools to help our clients assess how it will fare against its competition, its performance, its market readiness, and its quality and reliability.

Our founders, Mark L. Van Name and Bill Catchings, have worked together in technology assessment for over 20 years. As journalists, they published over a thousand articles on a wide array of technology subjects. They created and led the Ziff-Davis Benchmark Operation, which developed such industry-standard benchmarks as Ziff Davis Media’s Winstone and WebBench. They founded and led eTesting Labs, and after the acquisition of that company by Lionbridge Technologies were the head and CTO of VeriTest.