DELL 3-2-1 REFERENCE CONFIGURATIONS:
HIGH-AVAILABILITY PERFORMANCE WITH
DELL POWEREDGE R515 SERVERS

Dell” PowerEdge” R515 servers

delivered high-availability performance for 500+ users
with plenty of room for growth

Powered by AMD Opteron™ 4184 processors

Businesses need an IT infrastructure that can handle their growing performance
demands while maintaining high availability (HA), the ability to run with extremely little
to no downtime. Setting up a high availability infrastructure requires multiple servers,
switches, and storage, and businesses sometimes have difficulty selecting the
combination of hardware and software that will best meet their needs.

Dell makes things simple with Dell 3-2-1 Reference Configurations, proven
architectures designed to meet your needs. With Dell PowerEdge R515 servers powered
by AMD Opteron 4184 processors, the latest Dell PowerConnect™ 6428 switches, a Dell
Equallogic™ PS4000XV storage array, and a Dell PowerEdge R415 management server,
you can get all the performance you need and more.

We tested the performance capabilities of this architecture, and found that it
could simultaneously run three business applications while supporting over 500 users,
and still have headroom to spare for future growth. Not only did the configuration
perform well, but when we caused a server to fail, it failed over seamlessly, keeping
data safe and available.
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PERFORMANCE THAT WORKS

You need your data available at all times so that your business can thrive.
Scheduled downtime and hardware failures can bring your business screeching to a halt.
Setting up a high availability infrastructure is a smart move that protects your data,
applications, and your business. Placing your applications in virtual machines (VMs) on a
failover cluster, you can create a safety net should something go wrong—your VMs
move to the other server and quickly start working again in the event of a failure.

Setting up high-availability architecture can be difficult, but now Dell makes it
easy by offering Dell 3-2-1 Reference Configurations based on Dell PowerEdge R515
servers with AMD Opteron 4184 processors. To learn more about the setup process, see

our companion configuration guide.1
As easy as 3-2-1

Dell 3-2-1 Reference Configurations follow the 3-2-1 model, which means the
configuration comprises three servers, two switches, and one storage array. We created
a failover cluster with Hyper-V™ VMs on the Dell PowerEdge R515 servers, and used
them to run three applications businesses commonly use: Microsoft® SQL Server® 2008
R2 for database-based applications, Microsoft Exchange Server 2010 for email, and
Microsoft SharePoint® Server 2010 for collaboration.

We put the configuration to the test by simulating 600 users simultaneously
accessing the database, using email, and using SharePoint. Our finding? Not only could
the servers run these heavy workloads, they did so with plenty of resources to spare for
future growth.
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WHAT WE FOUND

In addition to measuring the performance the Dell PowerEdge R515 servers
provide, we also abruptly removed power from one of the host servers to simulate what
would happen in the case of a complete server failure. After we did so, the database VM
that was hosted on this server failed over seamlessly and began running on the other
Dell PowerEdge R515 with very little downtime; about a minute. Such seamless failover
means your data is available when you need it — even in the case of a server
catastrophe.

We set up three VMs across our two Dell PowerEdge R515 host servers to house
the applications—the database application ran on one server and the mail and
collaboration applications ran on the other. Our goal was to run workloads simulating
600 users in each VM to verify the configuration could handle the desired user load.
Because we wanted to maintain high availability, we needed to ensure that each server
could handle the load without oversubscribing resources so that they could failover if
necessary. Additionally, we ran the workloads while simulating a failover event to
demonstrate that a single host server would be able to maintain the same level of
performance.

Figure 2 shows the results for average CPU utilization for each VM while the
benchmarks were running, and Figure 3 shows the average resource utilization for the

host servers. Lower numbers are better.

Average % CPU utilization
SQL Server 2008 R2 (VM #1) 7.8
Exchange Server 2010 (VM #2) 27.3
SharePoint Server 2010 (VM #3) 16.8

Figure 2: CPU utilization for the VMs on our two Dell PowerEdge R515 servers.
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Hyper-V Host 1 (VMs #2 and #3) 171 59.4 8.6
Hyper-V Host 2 (VM #1) 3.2 354 6.4

Figure 3: Resource utilization for the two Dell PowerEdge R515 Hyper-V host servers.

As our results show, the servers were able to handle the load while maintaining
resource usage standards for high availability, and even had room for future growth.
The VMs only used a fraction of the virtual CPUs, and as Figure 3 shows, the host servers

and storage had plenty of resources left over.
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WHAT WE TESTED

Database testing

We chose workloads for each VM that would best test the capability of the
configuration to support 500+ users on each application. Figure 4 shows the benchmark

we used to test each VM, along with the median result (of three runs) for each.

VM Test Result

SQL Server 2008 R2 (VM #1) DVD Store Version 2 2,211 OPM (PASS)
Exchange Server 2010 (VM #2) LoadGen PASS
SharePoint Server 2010 (VM #3) WSSDW 1.0.0.0 Beta PASS

Figure 4: Median test results.

For more information on how we set up the tests to verify the performance
capabilities of our high-availability hardware setup, see the What we tested section.

To simulate our failover event, we removed power from one of the Hyper-V
hosts, specifically, the server that was hosting the SQL Server 2008 R2 database VM
while we were running the DVD Store workload. The failover cluster quickly detected
the failure of the host server and automatically migrated the VM to the other host
server. We were able to re-establish connection and continue the workload with only a
slight interruption. Furthermore, we measured the resource utilization on the single
host server running all three VMs under workload stress and found that the average
resource utilization was at 24.6 percent CPU, 82.9 percent RAM, and 16.5 percent disk,

with no observable change in performance.

We created a failover cluster using two Dell PowerEdge R515 servers with
cluster-shared volumes on the Dell EqualLogic PS4000XV storage array. We then used
Hyper-V to create three virtualized servers in the failover cluster to run the line-of-
business applications: a collaboration server running Microsoft SharePoint Server, a mail
server running Microsoft Exchange Server, and a database server running Microsoft SQL
Server. To demonstrate that each VM could handle over 500 users, we ran benchmarks
against each VM simultaneously to simulate 600 users accessing data on each. We
measured the performance of the three virtual machines over 30-minute test runs, and
report the median of three runs.

For step-by-step instructions on how we tested, see Appendix B.

We used the DVD Store Version 2 (DS2) benchmark to simulate 600 database
users. DS2 is an open-source application that models an online DVD Store where
customers log in, browse movies, and purchase movies. DS2 reports its results in orders
per minute (OPM) that the server can handle.

We ran DS2 with a 0.5-second think time, so that each of our 20 threads
represented 30 users (600 total) completing one order approximately every 15 seconds.
The benchmark then uses a default value of three searches on average before each
order. We define a minimum acceptable score as 1,920 OPM, or 80 percent of the
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Mail testing

Collaboration testing

expected results (80 percent of 4 OPM times the number of users) to take into account
variation in the number of searches the benchmark completed prior to each order.

For more details about the DS2 tool, see
http://www.delltechcenter.com/page/DVD+Store.

To test the configuration’s mail server performance, we used the Microsoft Load
Generator 2010 (LoadGen) benchmark, which performs tasks to simulate a standard
user generating mail activity. We simulated 600 users and used the following settings:

e Mailbox Profile: 100MB mailboxes

e Action Profile Average

e Client Type: Outlook 2007 Cached
LoadGen simulates the mail activity for the 600 users and then reports a PASS/FAIL
rating, which is based on acceptable response times.

For more details about LoadGen, see
http://www.microsoft.com/downloads/details.aspx?Familyld=DDEC1642-F6E3-4D66-
A82F-8D3062C6FA98&displaylang=en.

To simulate the traffic of 600 SharePoint Server 2010 users, we used the
WSSDW 1.0.0.0 Beta test. This test creates sample data, populates the server with it,
and simulates SharePoint Server users completing everyday tasks.

We used Visual Studio 2010 to execute the test workload, generating a realistic
user workload where each of the 600 simulated users performed a task every three
minutes. To do this, we set up the test to run 200 users with a 1-minute think time in
between each of the various tasks. The test workload then reports a PASS/FAIL rating
based on whether it was able to complete all of the tasks successfully.

For more details about SharePoint Server, see http://office.microsoft.com/en-

us/sharepoint-server-help/

WHAT THIS MEANS FOR YOU

Selecting a Dell 3-2-1 Reference Configuration consisting of Dell PowerEdge
R515 servers powered by AMD Opteron 4184 processors and Dell EqualLogic PS4000XV
storage for your high-availability infrastructure is a smart move for your business. By
choosing proven Dell architecture, you avoid the hassles of putting your infrastructure
together piece by piece and remove the potential for error.

Dell makes it easy for you to achieve the performance and reliability you need.
In our tests, we found that our highly available configuration built on Dell PowerEdge
R515 servers provided all the performance you need to support over 500 users while
leaving plenty of room for future growth.

Dell 3-2-1 Reference Configurations: High-availability performance A Principled Technologies test report 5
with Dell PowerEdge R515 servers


http://www.delltechcenter.com/page/DVD+Store
http://www.microsoft.com/downloads/details.aspx?FamilyId=DDEC1642-F6E3-4D66-A82F-8D3062C6FA98&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=DDEC1642-F6E3-4D66-A82F-8D3062C6FA98&displaylang=en
http://office.microsoft.com/en-us/sharepoint-server-help/
http://office.microsoft.com/en-us/sharepoint-server-help/

APPENDIX A — SERVER AND STORAGE CONFIGURATION INFORMATION

Figure 5 provides detailed configuration information for the servers in our configuration, and Figure 6 provides

configuration information for the Dell EqualLogic PS4000XV storage array.

System

Dell PowerEdge R415
(management server)

Dell PowerEdge R515
(Hyper-V host servers)

Power supplies

Total number 2 2

Vendor and model number Dell D500E-SO D750P-S0

Wattage of each (W) 500 750

Cooling fans

Total number 6 5

Vendor and model number San Ace 40 9CRD0412P5K05 Brushless PFC0612DE
Dimensions (h x w) of each 1.6” x 2.25" 2.5”x1.5”

Volts 12 12

Amps 1.20 1.68

General

Number of processor packages 2 2

Number of cores per processor 3 3

Number of hardware threads per core | 2 2

System power management policy Balanced Balanced

CPU

Vendor AMD AMD

Name Opteron Opteron

Model number 4170 HE 4184

Stepping D1 D1

Socket type C32 C32

Core frequency (GHz) 2.10 2.80

Bus frequency 6400 MT/s 6400 MT/s

L1 cache 64 KB + 64 KB 64 KB + 64 KB

L2 cache 3 MB (6 x 512 KB) 3 MB (6 x 512 KB)

L3 cache 6 MB (shared) 6 MB (shared)
Platform

Vendor and model number Dell PowerEdge R415 Dell PowerEdge R515
Motherboard model number 0GXHO08 03XOMN

BIOS name and version Dell 1.2.5 (3/16/2011) Dell 1.2.5 (3/16/2011)
BIOS settings Default Default

Memory module(s)

Total RAM in system (GB) 8 16

Vendor and model number M391B5773CHO-CH9 MT36JSZF51272PY-1G4D1AB
Type PC3-10600E PC3-10600R

Speed (MHz) 1,333 1,333

Speed running in the system (MHz) 1,333 1,333
Timing/Latency (tCL-tRCD-tRP- 9-9-9-24 9-9-9-24

tRASmin)
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Dell PowerEdge R415 Dell PowerEdge R515
System
(management server) (Hyper-V host servers)
Size (GB) 2 4
Number of RAM module(s) 4 4
Chip organization Single-sided Double-sided
Rank Single Dual
Operating system
Name Microsoft Windows Server 2008 R2 Microsoft Windows Server 2008 R2
SP1 Enterprise Edition SP1 Enterprise Edition
Build number 7601 7601
File system NTFS NTFS
Kernel ACPI x64-based PC ACPI x64-based PC
Language English English
Graphics
Vendor and model number Matrox® G200eW Matrox G200eW
Graphics memory (MB) 8 8
Driver Matrox 1.1.3.0 (7/27/2009) Matrox 1.1.3.0 (7/27/2009)
RAID controller
Vendor and model number Dell SAS 6/iR Dell PERC H700
Firmware version 25.47.00.06.22.03.00 12.10.1-0001
Driver version Dell 1.28.3.1 (7/9/2008) Dell 4.31.1.64 (8/9/2010)
Cache size (MB) N/A 512
Hard Drives
Vendor and model number Dell WD1602ABKS Dell MBA3147RC
Number of drives 2 2
Size (GB) 160 146
RPM 7,200 15,000
Type SATA SAS

Ethernet adapters

First network adapter

Broadcom® BCM5716C NetXtreme® Il | Broadcom BCM5716C NetXtreme Il
Vendor and model number

GigE GigE
Type Integrated Integrated
Driver Microsoft 4.8.4.1 (12/23/2008) Broadcom 6.2.9.0 (2/4/2011)
Second network adapter
Vendor and model number N/A ggsdcom BCMS5709C NetXtreme Il
Type N/A PCle
Driver N/A Broadcom 6.2.9.0 (2/4/2011)

Third network adapter

Broadcom BCM5709C NetXtreme Il

Vendor and model number N/A GigE

Type N/A PCle

Driver N/A Broadcom 6.2.9.0 (2/4/2011)
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System

Dell PowerEdge R415
(management server)

Dell PowerEdge R515
(Hyper-V host servers)

Optical drive(s)

Vendor and model number

TEAV DV28SW

TEAV DV28SW

Type DVD-ROM DVD-ROM
USB ports

Number 4 4

Type 2.0 2.0

Figure 5: System configuration information for the test servers.

Storage array

Dell EqualLogic iSCSI SAN

Array Dell EquallLogic PS4000XV
Number of active storage controllers 1

Number of active storage ports 2

Firmware revision Vv5.0.4

Switch number/type/model/ firmware revision

2 x Dell PowerConnect 6248 v3.2.1.3

Disk vendor and model number

16x Seagate ST3450856S5S

Disk size (GB) 450
Disk buffer size (MB) 16
Disk RPM 15,000
Disk type SAS

Figure 6: Detailed configuration information for the storage array.
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APPENDIX B - HOW WE TESTED

Figure 7 shows the recommended network cabling for a high-availability setup. To simplify our testing
configuration, we created an additional VLAN on the Dell PowerConnect 6248 switches and used this for the Public + VM
network/existing network infrastructure.

Dell PowerEdge R515 Dell PowerEdge R515

e =4

-8 Public + VM network
iISCSI network

-8 Live Migration network

-8 Private/CSV network

+ 4+ ¥+ Dell PowerEdge R415 -8 Stacking connections

— To existing infrastructure

Fv N

Figure 7: Our test bed setup.

We implemented stacking on the two Dell PowerConnect 6248 switches to provide ample connectivity between
the switches. Figure 8 shows how we configured the network cables across the NICs for each Dell PowerEdge R515.

NIC Port number Traffic type
1 Public/VM #1

Int ted on-board NIC

ntegrated on-boar 2 Private/CSV
1 iSCSI #1

Broadcom NetXtreme Il 5709 #1 I - X -
2 Live Migration
1 iSCSI #2

Broad NetXt 115709 #2

roadcom TetAtreme 2 Public/VM #2

Figure 8: NIC port configurations for each Dell PowerEdge R515.

We used a serial connection to access the basic setup wizard on the switches to configure an administrator
password and change the IP address to match our IP scheme. Figure 9 provides details on the IP scheme we used in our
testing.
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Subnet Traffic type Adapters assigned to this subnet

192.10.1.0 iSCSI iSCSI adapters(for this setup, there are four)

192.20.1.0 PUblic/VM Management server, stora'ge management, public/VM host server,
infrastructure server, and iDRAC management

192.30.1.0 Private/ CSV Private/CSV adapters (for this setup, there are two)

192.40.1.0 Live Migration Live Migration adapters (for this setup, there are two)

Figure 9: The IP scheme we used.

Figure 10 shows how we configured VLANs in the Dell PowerConnect 6248 switches to isolate the different types

of network traffic.

VLAN ID Traffic type Ports assigned to this VLAN

10 iSCSI iSCSI traffic ports from storage and servers (for this setup, there are four)

20 Public/VM Management server, storage management, public/VM host server NICs,
infrastructure server, iDRAC management, and outside access ports

30 Private/CSV Private/CSV ports (for this setup, there are two)

40 Live Migration Live Migration ports (for this setup, there are two)

Figure 10: VLAN configuration.

For all ports that handled iSCSI traffic, we enabled flow control, disabled unicast storm control, and enabled
jumbo frames. We also enabled jumbo frames on the NICs that handled iSCSI traffic. For more information, see the Dell
EqualLogic Configuration Guide at http://www.delltechcenter.com/page/Equallogic+Configuration+Guide.

We staggered the benchmark start times with 2 minutes between each benchmark, with DVD Store beginning
first, then Load Generator, then WSSDW 1.0.0.0 Beta, and allowed them to run simultaneously for 30 minutes. Between
tests, we restored the Mailbox and Public Folder stores by temporarily dismounting them and restoring them from a
backup. We used a script to restore the DVD Store database, which dropped the existing database and restored it from
the backup. After the restore finished, we rebooted the virtual machines and clients.

Starting DVD Store

We created a batch file to run the following parameters to begin the DVD Store test. We used the following
parameters in the batch file for testing the virtual machine:

ds2sglserverdriver.exe --target=192.20.1.6 --ramp rate=10 --run time=30 --
n threads=20 --db size str=V --think time=0.5 -warmup time=4 --
database name=DS2

1. Restart the DVD Store client and the virtual machine.
2. Open acommand prompt, and navigate to the location of the batch file.
3. Start the performance monitor counters, and kick off the batch file.

Starting LoadGen

1. Restart the mail client and the virtual machine.

2. Start Exchange Load Generator 2010, and load the configuration file.

3. Verify the test simulation settings, and start the performance monitor counters.

4. To start the test, select the option to skip the initialization phase, and begin the simulation.
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Starting WSSDW 1.0.0.0 Beta

1. Restart the virtual machine.
2. Open the benchmark file in Visual Studio.
3. Start the performance monitor, select the simulation, and click Run test.

Configuring the database (DVD Store)
Data generation overview

We built the database schema using the scripts in the DS2 distribution package, though we made a few minor
modifications. The DS2 stress tool provides options to generate 10MB, 1GB, or 100GB datasets. To get the tool to
generate the 5 GB of user data we used in this test, we had to make a few straightforward changes to the source code
and to the DVD Store application’s scripts. Note: We created our test data on a Linux system to take advantage of the
larger RAND MAX.

Editing the ds2_create_orders.c module

The module ds2_create_orders.c defines constants that define the maximum values for the customer ID and the
product ID. The constants for the 5GB database size did not exist. We added the constants for this size.

On the command line for the ds2_create_orders.c module, we specified the size. The available options were S
(small), M (medium), and L (large). We added the case V for the 5GB database. In the switch statement that sets the
values for the variables max_cust_id and max_prod_id, we added cases that assigned them the proper values for the
5GB database size.

We recompiled the ds2_create_orders.c module on Linux, following the instructions in the header comments.
We used the following command line:

gcc —o ds2 create orders ds2 create orders.c —1lm

Editing the ds2_create_cust.c module

We had to make the same changes to the ds2_create_cust.c module that we made to the ds2_create_orders.c
module. On the command line for the ds2_create_cust.c module, we specified the size. The available options were S
(small), M (medium), and L (large). We added the case V for the 5GB database. In the switch statement that sets the
values for the variables max_cust_id and max_prod_id, we added cases that assigned them the proper values for the
5GB database size.

We recompiled the ds2_create_cust.c module on Linux, following the instructions in the header comments. We
used the following command line:

gcc —-o ds2 create cust ds2 create cust.c —-1m

Generating the data for the 5GB database

We used shell scripts to run all four of the executables that generate the data. The distribution did not include
shell scripts for the 5GB size. We wrote shell scripts based on the ds2_create_cust_large.sh and
ds2_create_orders_large.sh scripts. The ds2_create_prod and ds2_create_inv executables did not ship with associated
shell scripts, so we created shell scripts using the instructions in the readme files. We ran the shell scripts in the
following order to generate the data for the 5GB database:

1. ds2 create orders 5gb.sh
2. ds2 create inv b5gb.sh
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3. ds2 create prod 5gb.sh
4. ds2 create cust 5gb.sh

We waited until the processes finished before we moved onto the next step.

Creating the database

We modified the database creation SQL Server scripts in the DVD Store distribution package to build the
database schema, which includes the file structure, tables, indices, stored procedures, triggers, and so on. We built the
5GB database in SQL Server 2008 R2, and then performed a full backup, storing the backup file on the C: drive for quick
access. We used that backup file to restore on both servers between test runs.

We followed these steps to create the database:

1. We created the database and file structure using database creation scripts in the DS2 download. We made size
modifications specific to our 5GB database and the appropriate changes to drive letters.

2. We created database tables, stored procedures, and objects.

3. We set the database recovery model to bulk-logged to prevent excess logging.

4. We loaded the data we generated into the database. For data loading, we used the import wizard in SQL Server
Management Studio. Where necessary, we retained options from the original scripts, such as Enable Identity
Insert.

5. We created indices, full-text catalogs, primary keys, and foreign keys using the database-creation scripts.

6. We updated statistics on each table according to database-creation scripts, which sample 18 percent of the
table data.

7. On the default SQL Server instance, we created a ds2user SQL Server login using the following Transact SQL
(TsQl) script:

USE [master]

GO

CREATE LOGIN [ds2user] WITH PASSWORD=N'"',
DEFAULT DATABASE= [master],
DEFAULT_LANGUAGE= [us_english] ,
CHECK_EXPIRATION=OFF,
CHECK_POLICY=OFF

GO

8. We set the database recovery model back to full.
9. We made the following changes in the build scripts:

e Because we varied the size of the datasets, we sized the files in our scripts to reflect the database size and the
number of files per filegroup. We allowed for approximately 40 percent free space in our database files to
ensure that filegrowth activity did not occur during the testing.

o We followed Microsoft’s recommendation of having 0.25 to 1 file per filegroup per core.

e We did not use the DBCC PINTABLE command for the CATEGORIES and PRODUCTS tables, both because
Microsoft recommends against this practice and because the commands do nothing in SQL Server 2008.

e When running tests in SQL Server 2008, we added the FORCESEEK hint in the BROWSE_BY_ACTOR and
BROWSE_BY_TITLE stored procedures because in initial testing we found that SQL Server 2008 was choosing an
index scan instead of the preferred index seek, adding unnecessary overhead. We included this in the initial
build and backup process we describe above.
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e We created a SQL Server login we called ds2user and mapped a database user to this login. We made each
such user a member of the db_owner fixed database role.

e Using the DVD Store scripts as a reference, we created the full-text catalog and index on the PRODUCTS table
manually in SQL Server Management Studio.

We then performed a full backup of the database. This backup allowed us to restore the databases to a pristine
state relatively quickly between tests.

Editing the workload script - ds2sqlserverfns.cs module

We changed the connection string to increase the number of available connections, to not use the default
administrator (“sa”) account, and to include a parameter for the database name. We raised the available connections
limit from the default of 100 to 200 to allow room for experimentation. We created a user account we called ds2User
and used that account.

The ds2connect routine in the ds2sqlserverfns.cs module defines sConnectionString. We used the following
string; the changes we made appear in bold:

string sConnectionString = “User ID=ds2User;Initial Catalog=“+dbname+”;Max
Pool Size=200;Connection Timeout=120;Data Source=" + Controller.target;

Recompiling the ds2sqlserverdriver.exe executable

We recompiled the ds2xdriver.cs and ds2sqlserverfns.cs module in Windows by following the instructions in the
header comments. Because the DS2 instructions were for compiling from the command line, we used the following
steps:

1. Open acommand prompt.

2. Use the cd command to change to the directory containing our sources.

3. Run the batch file C:\Program Files\Microsoft Visual Studio 9.0\Common7\Tools\vsvars32.bat. This sets up the
environment variables for us.

4. Execute the following command:

csc /out:ds2sglserverdriver.exe ds2xdriver.cs ds2sglserverfns.cs
/d:USE_WIN32 TIMER /d:GEN_ PERF CTRS

Setting up the infrastructure server

To provide an existing hardware infrastructure for our Dell 3-2-1 Reference Configuration hardware, we
prepared a Dell PowerEdge T105 to serve as our Active Directory and DNS server by installing a fresh copy of Windows
Server 2008 R2 SP1 Enterprise Edition, and installing the Active Directory Domain Services, DNS, and the Active Directory
Certificate Services role.

1. Set a static IP address using the following steps:
a. Right-click the network icon in the quick-launch bar, and choose Network and Sharing Center.
Click Manage network connections.
Right-click the local area connection, and choose Properties.
Select Internet Protocol Version (TCP/IPv4), and click Properties.
Select the Use the following IP address radio button, and type 192.20.1.1 in the IP address field.
Press Tab to auto-fill 255.255.255.0 in the Subnet mask field.

~o oo o
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g. Click Close.
2. Give the system a name using the following steps:
Click Start, right-click Computer, and select Properties.
Click Change Settings.
Click Change.
Type activedirectory in the Computer name field, and click OK.
In the Computer Name/Domain Changes pop-up window, click OK.
Click OK.
g. Inthe Microsoft pop-up window, click Restart Now.
3. Promote the mail server to domain controller by following these steps:
a. Select Start>Command Prompt.
Type dcpromo
At the Welcome pop-up window, click Next.
At the Operating System Compatibility screen, click Next.
At the Choose a Deployment Configuration screen, select the Create a new domain in a new forest radio
button, and click Next.
At the Name the Forest Root Domain screen, type the domain name test.local and click Next.
g. Atthe Set Forest Functional Level screen, choose Windows Server 2008 R2 from the drop-down menu,
and click Next.
h. At the Set Domain Functional Level screen, choose Windows Server 2008 R2 from the drop-down menu,
and click Next.
At the Additional Domain Controller Options screen, accept the defaults, and click Next.
When the Active Directory domain Services Installation Wizard window pops up, click Yes.
At the Location for Database, Log Files, and SYSVOL screen, click Next.
At the Directory Services Restore Mode Administrator Password screen, enter a password, and click
Next.
m. At the Summary screen, review the selections, and click Next.
n. Atthe Completing the Active Directory Installation Wizard screen, click Finish.
0. When the system prompts you to reboot the server, click Restart Now.
p. After the server reboots, log into the system.

~P oo oo
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Creating the tester user

1. Select Start=>All Programs—>Administrative Tools=> Active Directory Users and Computers.

2. Inthe Active Directory Users and Computers window, select the server in the left pane, and open Users in the

right pane.

Right-click a blank area in the Users folder, and select New—> User.

In the New Object - User window, complete the name fields as you wish (we used first name: test, last name:

tester, logon name: tester), and select Next.

Enter a secure password (we used Password1), and check Password never expires.

In the pop-up information window, click Accept.

Select Next to close the New Object — User window.

Double-click the new user to bring up the Properties window.

Under the Member Of tab, click Add.

10. In the Enter the object names to select dialog box, type Domain Admins; Enterprise Admins;
Organization Management select Check Names to verify, and click OK.

11. Click OK to close the User Properties window, and close the Active Directory Users and Computers window.

s w
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Setting up the Hyper-V host servers

We used the BIOS RAID configuration utility to create RAID 1 partitions on the Dell PowerEdge R515 servers for

the operating system. Following the operating system installation, we installed all important Windows updates through
April 20, 2011.

Installing Windows Server 2008 R2

=

O NOU A WN

N Y
w N - O

Insert the installation DVD for Windows Server 2008 R2 into the DVD drive.
Choose the language, time and currency, and keyboard input. Click Next.
Click Install Now.

Choose Windows Server 2008 R2 Enterprise (Full Installation). Click Next.
Accept the license terms, and click Next.

Click Custom.

Click the Disk, and click Drive options (advanced).

Click New—>Apply=>Format, and click Next.

After the installation completes, click OK to set the Administrator password.

. Enter the administrator password twice, and click OK.

. Click Start, type change power-saving settings and press Enter.
. Click Change plan settings.

. Change the Turn off the display drop-down menu to Never.

14.

Click Save changes, and close the Power Options, Screen Saver Settings, and Personalization windows.

Installing Dell EqualLogic Host Integration Tools
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11.
12.

Insert the disk, and click Setup.exe.

At the Welcome screen, click Next.

At the License Agreement screen, click Next.

At the Installation Type screen, select Typical (Requires reboot on Windows Server platforms), and click Next.
In the Microsoft iSCSI Initiator service is not running pop-up, click Yes to start the service and enable iSCSI traffic
through the firewall.

In the Microsoft iSCSI service pop-up, click Yes.

When the iSCSI Initiator Properties window pops up, accept the defaults, and click OK.

If a Windows Firewall Detected pop-up appears, click Yes to enable echo requests.

At the Ready to install the components screen, click Install.

In the Microsoft Multipath 1/0 feature is not detected pop-up, click Yes to install the feature.

At the Installation Complete screen, click Finish.

In the System Restart Required pop-up, select Yes, | want to restart my computer now, and click OK.

Running the Remote Setup Wizard for the Dell EqualLogic PS4000XV

1.
2.

Click Start>All Programs—>Equallogic, and open Remote Setup Wizard.

At the Welcome screen, leave the radio button on Initialize a PS Series array, and click Next. The Remote Setup
Wizard will search for uninitialized PS Series arrays.

At the All PS Series arrays have been initialized screen, select the storage array, and click Next.

At the Initialize Array screen, enter PS4000Storage for Member Name, 192.10.1.11 for IP Address,
255.255.255.0 for Subnet Mask, and 192.10.1 .1 for Default Gateway.

Under Group Information, leave the Create a new group radio button selected, and click Next.

At the Create a New Group screen, enter grpmanager for the Group Name and 192.10.1.10 for the Group
IP Address.

On the Create a New Group screen, select the desired RAID level. We selected RAID 10 for the RAID Policy.
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8.
9.

Under Credentials for New Group, enter the passwords.
Under CHAP credentials for VDS/VSS access to group, enter a user name and password, and click Next.

10. On the Initialization Successful pop-up, click OK.
11. Click Finish.

Configuring MPIO settings

1.
2.

4.
5.
6.

Click Start=>All Programs—> EqualLogic=> Remote Setup Wizard.

At the Welcome to the Remote Setup Wizard screen, select Configure MPIO settings for this computer, and click
Next.

Under Subnets included for MPIO, select all subnets except for 192.10.1.0 to be excluded from MPIO, where
192.10.1.0 is the subnet handling iSCSI traffic.

Click Exclude.

Change the Max sessions per entire volume from 6 to 12.

Click Finish.

Configuring the Dell EqualLogic PS4000XV storage

1.

NowukwnN

9.

Click Start=>Internet Explorer, and enter the IP address of the Dell EquallLogic PS Series Group Manager. For our
testing, we used 192.10.1.10.

Log into the group manager using the credentials you created during the Remote Setup Wizard.

Expand Members, click the member PS4000Storage, and, in the right pane, select the Network tab.

Right-click eth1, and select Modify IP settings.

Type 192.10.1.12 for the IP address and 255.255.255. 0 for the Subnet mask, and click OK.

Right-click eth1, and select Enable interface.

Repeat steps 4 and 5 for eth2 which is the management port, entering 192.20.1.10 for the IP address, and
255.255.255.0 for the subnet mask.

Create the volumes:

a. Inthe left pane, click Volumes, and, in the adjacent pane, click Create volume.

b. Name the volume VirtualMachines and click Next.

Type 300 for the Volume size, and click Next. For our testing purposes, we did not create a snapshot
reserve with the volume.

d. On the Step 3 —iSCSI Access screen, check the Limit access to iSCSI initiator name checkbox, enter the
appropriate iSCSl initiator name, and click the Allow simultaneous connections from initiators with
different IQN names checkbox. For our testing, this was ign.1991-
05.com.microsoft:hypervhostl.test.local

e. Click Finish.

Repeat Step 8 six times for the remaining volumes, using the following names and volume sizes:

SharePoint - 500GB
Exchange - 500GB
ExchangelLog - 125GB
SQLData - 500GB
SQLLog - 125 GB
DiskWitness — 10 GB

Connecting to the volumes with Microsoft iSCSI Initiator

swnN

Click Start=> Administrative Tools=iSCSI Initiator.

Select the Discovery Tab, and click Discover Portal.

Enter the IP address for the Dell EqualLogic Storage Group, and click OK.
Select the Targets tab, and click Refresh.
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7.

Select the first Inactive Target listed, and click Connect.

Ensure that Add this connection to the list of Favorite Targets is selected, check the Enable multi-path check box,
and click OK.

Repeat steps 5 and 6 six times, until you’ve connected to all seven volumes, and click OK.

Installing Broadcom Advanced Control Suite

AW

Nowu

8.

On the Dell Update Package pop-up for installing Broadcom NetXtreme Family of Adapters, click Install...

On the InstallShield Wizard welcome screen, click Next.

Click the | accept the terms in the license agreement radio button, and click Next.

Under Drivers and Management Applications, click Control Suite, click BASP, select to install this feature on the
local hard drive in the drop-down menu, and click Next.

On the Ready to Install the Program screen, click Next.

At the pop-up warning screen, click Yes.

On the InstallShield Wizard Completed screen, click Finish.

At the Update Package Complete screen, click OK.

Configuring a NIC team with the Public/VM NICs in BACS
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Click Start->All Programs—>Broadcom—>Broadcom Advanced Control Suite 3.

Click Team Management.

Click Teams from the taskbar, and select Create a Team to launch the Broadcom Teaming Wizard.

At Welcome to the Broadcom Teaming Wizard screen, click Next.

In the textbox, enter Public-VM Teamed NIC, and click Next.

For Team type, select the Smart Load Balancing™ and Failover (SLB) radio button, and click Next.

At the Assigning Team Members screen, select the two Public-VM-dedicated NICS, click Add, and click Next.
Select Do not configure a standby member, and click Next.

On the Configuring Livelink screen, select the No radio button, and click Next.

. On the Configure VLAN Support screen, select the Skip manage VLAN radio button, and click Next.
. Under Commit changes, select the Commit changes to system and Exit the wizard radio button, and click Finish.
. On the pop-up that states Applying the changes will temporarily interrupt the network connection, click Yes.

When the configuration process finishes, you should see the newly created virtual adapter from the teamed
NICs.

Adding the Hyper-V role

LN A WNE

10

11.
12.

Open Server Manager, and click Roles.

Click Add Roles.

On the Before You Begin page, check the Skip this page by default box, and click Next.
Select Hyper-V, and click Next.

On the Hyper-V Introduction page, click Next.

On the Create Virtual Networks page, click Next.

Confirm installation selections, and click Install.

Once the installation is complete, click Close.

When the system prompts a restart, click Yes.

Allow the system to fully reboot, and log in using the administrator credentials.

Once the desktop loads, the Hyper-V Installation Results window will finish the installation.
Click Close. The Hyper-V role will now be available in Server Manager under Roles.
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Configuring the Dell EqualLogic PS4000XV for access from the second Hyper-V host server

1.

w

Click Start=>Internet Explorer, and enter the IP address of the Dell EqualLogic PS Series Group Manager. For our
testing, we used 192.10.1.10.

Log into the group manager using the credentials you created during the Remote Setup Wizard.

Click on the Volume, click the Access tab, and click Add.

Check the Limit access to iSCSI initiator name checkbox, enter the iSCSI initiator name of the second Hyper-V
host server, and click OK. For our testing, this was ign.1991-
05.com.microsoft:hypervhost2.test.local.

Repeat steps 3 and 4 six times for the remaining volumes:

SharePoint

Exchange

Exchangelog

SQLData

SQlLog

DiskWitness

Creating a VLAN and assigning ports on the Dell PowerConnect 6248 switch

NV kWM

10.

Open a Web browser, and enter the IP address of the switch. For our testing, this was 192.20.1.250.

Enter the appropriate login credentials.

In the left pane, expand Switching, VLAN, and click VLAN Membership.

In the right pane, click Add.

Enter the first VLAN ID and Name, and click Apply Changes.

Repeat Step 5 three more times to create the remaining VLANSs.

When you finish, click Back. The VLAN drop-down menu should show the newly created VLANSs.

To add a port to a VLAN, select the appropriate VLAN from the drop-down menu, and click the desired ports in
the Static row.

Click Apply Changes to save the VLAN port assignments.

Repeat steps 8 and 9 three more times to complete the port assignments for the remaining three VLANs on Unit
1, then click to select Unit 2 (the other switch), and repeat steps 8 and 9 for all VLANSs.

Preparing the failover cluster

Complete the following steps on both Hyper-V host servers:

Creating a self-signed certificate
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11.
12.

Click Start=>Run.

Type mmc, and click OK.

When the console opens, click File>Add/Remove Snap-in...
Under Available snap-ins, select Certificates, and click Add.
Select Computer account, and click Next.

Select Local computer, and click Finish.

At the Add or Remove Snap-ins window, click OK.

On the left side, expand Certificates (Local Computer).

Right-click Personal, and click All Tasks=>Request New Certificate.
On the Before You Begin page, click Next.

On the Select Certificate Enrollment Policy page, click Active Directory Enrollment Policy, and click Next.
Check the Computer box, and click Enroll.
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13.

Once the certificate installation completes, click Finish. The new certificate will now be listed under Certificates
(Local Computer)—>Personal—>Certificates.

Installing Dell OpenManage Server Administrator 6.4

1.
2.
3.

12.
13.

Insert the installation disk for Dell OpenManage Server Administrator into the DVD drive.

When the AutoPlay window appears, click Run autorun.exe.

When the Dell OpenManage Install window appears, click Install.

The install wizard scans for prerequisites.

If a Remote Enablement warning is listed, click the link to configure HTTPs Listener Windows Remote
Management.

When the Are you sure you want to configure HTTPs Listener Windows Remote Management prompt appears,
click Yes.

When the configuration tool completes, click Rescan Dependencies.

When the scan completes, click Server Administrator.

At the Welcome to the Install Wizard for Dell OpenManage Server Administrator screen, click Next.
Accept the license agreement, and click Next.

. At the Setup Type screen, select Custom, and click Next.
. At the Custom Setup screen, click Server Instrumentation—>Remote Enablement->This feature will be installed

on the local hard drive, and click Next.
At the Ready to Install the Program screen, click Install.
Once the installation completes, click Finish.

Installing the failover clustering feature on the Hyper-V host servers

Open Server Manager, and click Features.

Click Add Features.

Select Failover Clustering, and click Next.

Click Install.

Once the new feature installation completes, click Close.

Running the Validate a Configuration Wizard

ukhwnN e

6.
7.
8.

Complete the following steps on only one of the Hyper-V host servers:

Open Server Manager.

Expand Features, and select Failover Cluster Manager.

Click Validate a Configuration...

On the Before You Begin page, check the Do not show this page again box, and click Next.

At the Select Servers page, type the name of each Hyper-V host server, and click Add. After adding both servers,
click Next.

On the Testing Options page, select Run all tests (recommended), and click Next.

On the Confirmation page, click Next to begin running the validation tests.

Once the validation tests complete successfully, click Finish.

Creating and configuring the cluster

Bl

Complete the following steps on only one of the Hyper-V host servers:

Open Server Manager.

Expand Features, and select Failover Cluster Manager.

Click Create a Cluster...

On the Before You Begin page, check the Do not show this page again box, and click Next.
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On the Select Servers page, type the name of each Hyper-V host server and click Add. After adding both servers,
click Next.

On the Access Point for Administering the Cluster page, type Del1Cluster as the cluster name.

Select a valid network, enter the desired IP address, and click Next.

On the Confirmation page, click Next.

Once the new cluster is created and configured, click Finish.

. The new cluster now appears under Server Manager-> Features—>Failover Cluster Manager.

. Select the newly created cluster.

. Click Enable Cluster Shared Volumes...

. Read the notice window that appears, check the | have read the above notice box, and click OK.

. On the left side of the Server Manager window, expand the new cluster, and click Cluster Shared Volumes.

. Click Add storage.

. Select the desired disks, and click OK to add the disks to the cluster.

. Once the Add storage task completes, the added disks will now be listed on the main page for Cluster Shared

Volumes.

Configuring the management server

We set up our management server with a copy of Windows Server 2008 R2 Enterprise Edition, applied an IP

address, and joined it to the domain.

Creating a self-signed certificate
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Click Start=>Run.

Type mmc, and click OK.

When the console opens, click File>Add/Remove Snap-in...
Under Available snap-ins, select Certificates, and click Add.

Select Computer account, and click Next.

Select Local computer, and click Finish.

At the Add or Remove Snap-ins window, click OK.

On the left side, expand Certificates (Local Computer).

Right-click Personal, and click All Tasks=> Request New Certificate.

. On the Before You Begin page, click Next.

. On the Select Certificate Enrollment Policy page, click Active Directory Enrollment Policy, and click Next.

. Check the Computer box, and click Enroll.

. Once the certificate installation completes, click Finish. The new certificate will now be listed under Certificates

(Local Computer)->Personal—> Certificates.

Installing Dell OpenManage Server Administrator 6.4

N

Insert the installation disk for Dell OpenManage Server Administrator into the DVD drive.

When the AutoPlay window appears, click Run autorun.exe.

When the Dell OpenManage Install window appears, click Install.

The install wizard scans for prerequisites.

If a Remote Enablement warning is listed, click the link to configure HTTPs Listener Windows Remote
Management.

When the Are you sure you want to configure HTTPs Listener Windows Remote Management prompt appears,
click Yes.

When the configuration tool completes, click Rescan Dependencies.

When the scan completes, click Server Administrator.

At the Welcome to the Install Wizard for Dell OpenManage Server Administrator screen, click Next.
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9.

10.
11.

12.
13.

Accept the license agreement, and click Next.

At the Setup Type screen, select Custom, and click Next.

At the Custom Setup screen, click Server Instrumentation—=>Remote Enablement—>This feature will be installed
on the local hard drive, and click Next.

At the Ready to Install the Program screen, Click Install.

Once the installation completes, click Finish.

Installing Hyper-V Tools and failover clustering tools

1.

ouhkwnN

7.

Open Server Manager, and click Features.

Click Add Features.

On the Select Features page, expand Role Administration Tools, and select Hyper-V Tools.
Expand Feature Administration Tools, and select Failover Clustering Tools.

Click Next.

On the Confirm Installation Selections page, click Install.

Once the installation is complete, click Close.

Installing Systems Center Essentials 2010

10.
11.
12.

13.
14.
15.
16.

17.

Insert the System Center Essentials installation DVD into the DVD drive.

When the AutoPlay window appears, click Run setupSCE.exe.

At the System Center Essentials 2010 Setup window, check the Download the latest updates to System Center
Essentials 2010 during setup box, and click Install.

On the Product registration information page, enter a name, an organization, and your product key, and click
Next.

When prompted, install .NET Framework 3.5 SP1.

At the license agreement, check the | have read, understood, and agree with the terms of the license agreement
box, and click Next.

On the Select components to install page, ensure that all components are selected, and click Next.

The wizard will then check the environment for prerequisite hardware and software. Review and correct any
prerequisite warnings, and click Next.

On the Setup will install these missing software prerequisites page, select Install Internet Information Services
(11S) and Install SQL Server 2008 SP1 on this computer now, and click Next.

When all prerequisite installations complete successfully, click Next.

On the Where should System Center Essentials files be located page, click Next.

On the Where should Virtualization Management data be located page, accept the default location, and click
Next.

On the Provide management account credentials page, enter the administrator user name and password, enter
the proper domain name, and click Test.

When the test completes, click Next.

On the Help improve System Center Essentials page, select No for all three items, and click Next.

On the Ready to install System Center Essentials page, review the Essentials Server and Essentials Reporting
settings, and click Install.

When the installation completes successfully, check the Open the System Center Essentials console when this
wizard closes, and click Close.

Configuring Systems Center Essentials 2010

1.
2.
3.

On the Get Started page, click Start.
On the Policy Type page, select Yes, and click Next.
On the Firewall Exceptions page, select Yes, create Windows Firewall exceptions (recommended), and click Next.
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12.
13.
14.
15.

16.
17.
18.

On the Configure Remote Assistance page, select No, do not enable Remote Assistance, and click Next.
On the Computer Discovery page, select Yes.

Select Automatically discover and manage all computers, and click Next.

On the E-mail Notifications page, select No, | will set up notifications later, and click Next.

On the Proxy Server page, select No, and click Synchronize.

Once the synchronization is complete, click Next.

. On the Monitoring Configuration page, leave default selections, and click Next.
. On the Error Monitoring page, select Yes, collect application errors (recommended), enter a valid directory for

the Error reporting upload location, and click Next.

On the Configure Error Forwarding page, click Next.

On the Microsoft Updates page, select Automatically (recommended), and click Next.

On the Update Languages page, select Yes (recommended), and click Next.

On the Update Classifications page, select Download only critical, security, and service pack updates from
Microsoft (recommended), and click Next.

On the Update Deployment page, leave default selections, and click Next.

On the Summary page, review the configuration, and click Configure.

Once the configuration completes, check the Start discovering computers to manage when this wizard closes,
and click Close. Allow for the SCE console to install management agents on the discovered computers before
proceeding.

Adding the failover cluster as a virtual machine host in SCE 2010
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10.
11.
12.

Open System Center Essentials 2010.

On the left-hand pane, click Computers.

In the Computer Overview pane, click Designate a Host under Virtualization.

On the Select a Computer screen, select the first virtualization host.

Click Next.

Enter the administrator credentials and domain.

Click Designate.

When the validation prompt appears, click OK.

At the Network Configuration screen, select the BASP Virtual Adapter and enter Public-VM Teamed NIC, set all
other network adapters to Do not configure, and click Next.

Repeat Step 9 for the second node.

At the Summary screen, click Create.

At the Completion screen, check the When the wizard closes, take me to view the new host checkbox, and click
Close.

Importing the Dell PRO enabled management pack into SCE 2010

1.

LN U A WN

Download the Dell PRO Pack 2.0 from
http://support.us.dell.com/support/downloads/download.aspx?c=us&cs=555&|=en&s=biz&releaseid=R252410
&formatcnt=1&libid=0&typeid=-1&dateid=-1&formatid=-1&fileid=369241.

Double-click the downloaded file.

When the Open File — Security Warning window appears, click Run.

At the Dell PRO Enabled Management Pack window, click OK.

Enter a location for the unzipped file, and click Unzip.

When the unzip process is complete, click OK.

Open Systems Center Essentials.

When the System Center Essentials console appears, click Administration on the left side.
Under Tasks, click Import Management Packs...
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10.
11.
12.
13.
14.
15.

On the Select Management Pack page, click Add—=>Add from disk...
At the Online Catalog Connection prompt, click No.

Browse to the unzipped Dell PRO Pack, and click Open.

Once the Dell PRO Pack has been added, click Install.

At the System Center Essentials security prompt, click Yes.

Once the management pack is successfully imported, click Close.

Creating a virtual machine in SCE 2010
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11.
12.

13.
14.
15.
16.
17.
18.
19.
20.
21.
22.

Repeat these steps for each of the three virtual machines:

Open System Center Essentials 2010.

On the left side, select Computers.

On the right side, click New Virtual Machine under Computer Group.

At the Select Template screen, select an appropriate template, and click OK.

At the Installing Operating System screen, select Install from DVD, insert the Windows Server 2008 R2 SP1 install
disk into the appropriate Hyper-V host server, and click Next.

Select a host for the new virtual machine, and click Next.

At the Virtual Machine Name screen, enter a name, description, and host folder for the new VM.

Click Next.

At the Summary screen, review the virtual machine settings, and click Create.

. When the virtual machine is successfully created, check the When the wizard closes, and open the Configure

Virtual Machine window to set up the VM for management box.

Click Close.

When the Configure Virtual Machine window appears, click Install an operating system. A VM window pops up
showing that the Windows Server 2008 R2 SP1 files are being loaded from the DVD.

At the Language Selection Screen, click Next.

Click Install Now.

Select Windows Server 2008 R2 Enterprise (Full Installation), and click Next.

Click the | accept the license terms check box, and click Next.

Click Custom.

Click Next.

At the User’s password must be changed before logging on warning screen, click OK.

Enter the desired password for the administrator in both fields, and click the arrow to continue.
At the Your password has been changed screen, click OK.

Click OK, and click Close to exit.

Configuring a virtual machine in SCE 2010

Before proceeding with this section, ensure that your virtual machine has been configured with an appropriate

name, IP address, and that it has been joined to the existing domain.

1.

2.
3.
4

U

At the Configure Virtual Machine VM1 screen, click 3. Add the new virtual machine to management.

On the What would you like to manage? screen, select Windows computers, and click Next.

On the Auto or Advanced? screen, select the Automatic computer discovery radio button, and click Next.

On the Administrator Account screen, select the Use selected Management Server Action Account, and click
Discover.

On the Select Objects to Manage screen, select the appropriate virtual machine, and click Next.

On the Summary screen, click Finish. The Agent Management Task Status window pops up and shows the status
of the agent installation into the virtual machine.

When the task has completed and the Status says Success, click Close.
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Configuring the Live Migration networks for the virtual machines
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Click Start=>Administrative Tools=>Failover Cluster Manager.

Click Manage a Cluster.

Enter the cluster name, and click OK.

Expand the cluster name, services and applications, and click SCVMM VM resources for the first virtual machine.
In the center pane, right-click SCVMM <virtualmachinename>, and click Properties, where
<virtualmachinename> is the name of your VM.

Click the Network for live migration tab.

Use the Up and Down buttons to order the networks by priority, with the dedicated Live Migration network first,
followed by the Private/CSV network, then the Public network, and verify that the iSCSI network is disabled for
live migration. Click OK.

This should automatically set the live migration priorities for all virtual machines.

Adding additional storage volumes to the virtual machines
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10.

11.
12.

13.
14.
15.

Click Start->Administrative Tools>Hyper-V Manager.

Under each Hyper-V host, shut down the VMs by selecting them and clicking Shut Down.

Right-click the first VM, and click Settings...

Select Add Hardware, highlight SCSI Controller, and click Add.

Click Add to select Hard Drive.

In the Hard Drive screen, under Media, select the Virtual hard disk radio button, and click New.

At the Before You Begin screen, click Next.

At the Choose Disk Type screen, select the Fixed size radio button, and click Next.

At the Specify Name and Location screen, enter an appropriate name and change the location so that the virtual
hard disk is in the appropriate volume. For example, create a virtual hard disk within the SharePoint volume on
the VM that you will designate as your SharePoint Server. Be sure to select the storage from within
C:\ClusterStorage on your Hyper-V host server.

At the Configure Disk screen, select the Create a new blank virtual hard disk radio button, enter a size, and click
Next. For testing purposes, we allocated 200GB virtual hard disks for SQL and Exchange databases and 50GB
virtual hard disks for each log.

Click Finish.

For the SQL Server and Exchange Server VMs, you will need to repeat steps 4 through 11 to add the second
volume. When you are finished adding the volumes, click Apply, and click OK.

Start the virtual machine.

In Server Manager, use Disk Management to bring the disks online within each VM.

Repeat steps 1 through 14 for the remaining VMs.

Preparing VM #1

Installing Microsoft SQL Server 2008 R2

1.
2.

E

On the management server, click the Start button, and click Hyper-V Manager.

Select the appropriate Hyper-V Host machine, right-click the virtual machine on which you wish to install SQL
Server, and choose to connect.

Log into the virtual machine.

Insert the installation DVD for SQL Server 2008 R2 into the appropriate Hyper-V host server’s DVD drive.

Using the Hyper-V menu, choose Media, and Capture D: Drive, where D: is the letter of the physical server’s DVD
drive.
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11.
12.
13.
14.

15.
16.

17.
18.
19.
20.

21.
22.
23.
24,
25.
26.

27.
28.
29.
30.
31.
32.

33.
34.

Click Run SETUP.EXE. If Autoplay does not begin the installation, navigate to the SQL Server 2008 R2 DVD, and
double-click.

If the installer prompts you with a .NET installation prompt, click Yes to enable the .NET Framework Core role.
In the left pane, click Installation.

Click New installation or add features to an existing installation.

. At the Setup Support Rules screen, wait for the check to complete. If there are no failures or relevant warnings,

click OK.

Select the Enter the product key radio button, and enter the product key. Click Next.

Click the checkbox to accept the license terms, and click Next.

Click Install to install the setup support files.

If there are no failures displayed, click Next. You may see a Computer domain controller warning and a Windows
Firewall warning. For now, ignore these.

At the Setup Role screen, choose SQL Server Feature Installation.

At the Feature Selection screen, select Database Engine Services, Full-Text Search, Client Tools Connectivity,
Client Tools Backwards Compatibility, Management Tools —Basic, and Management Tools — Complete. Click Next.
At the Installation Rules screen, click Next once the check completes.

At the Instance configuration screen, leave the default selection of default instance, and click Next.

At the Disk space requirements screen, click Next.

At the Server configuration screen, choose NT AUTHORITY\SYSTEM for SQL Server Agent, and choose NT
AUTHORITY\SYSTEM for SQL Server Database Engine. Click Next.

At the Database Engine Configuration screen, select Mixed Mode.

Enter and confirm a password for the system administrator account.

Click Add Current user. This may take several seconds.

Click Next.

At the Error and usage reporting screen, click Next.

At the Installation Configuration rules screen, check that there are no failures or relevant warnings, and click
Next.

At the Ready to Install screen, click Install.

After installation completes, click Next.

Click Close.

Create a SQL Server login for the ds2user (see the Configuring the database server (DVD Store) section for
the specific script to use).

Place the DVD Store backup file you prepared in the default location for SQL Server: C:\Program Files\Microsoft
SQL Server\MSSQL10.MSSQLSERVER\MSSQL\Backup.

Click Start=>All Programs—>Microsoft SQL Server 2008 R2-> Configuration Tools, and click SQL Server
Configuration Manager

Expand SQL Server Network Configuration, and click Protocols for MSSQLSERVER.

Right-click TCP/IP, and select Enable.

Preparing VM #2

Installing .NET Framework 3.5.1 Features and Internet Information Services

1.
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Select Start—>Administrative Tools—>Server Manager.
Click Features.

Click Add Features.

Select .NET Framework 3.5.1 Features, and click Install.
Click Add Required Role Services.

Click Next.
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9.

10.

Click Next.

At the Select Role Services screen, select the IIS 6 Metabase Compatibility, [IS 6 Management Console, Basic
Authentication, Windows Authentication, Digest Authentication, and Dynamic content Compression checkboxes,
and click Next.

At the Confirm Installation Selections screen, click Install.

At the Installation Results screen, click Close.

Installing Microsoft Filter Pack 2.0

1.

W

5.

Download the Microsoft Filter Pack 2.0.
(http://www.microsoft.com/downloads/en/details.aspx?FamilylD=5cd4dcd7-d3e6-4970-875e-aba93459fbee)
Run FilterPackx64.EXE.

Click Next.

Click I accept the terms in the License Agreement, and click Next.

When the installation is complete, click OK.

Installing Exchange Server 2010
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16.
17.
18.
19.

20.
21.
22.

Click Start, type services and press Enter.

Right-click the Net.Tcp Port Sharing service, and click Properties.

Change the Net.Tcp Port Sharing startup type to Automatic, and click OK.
Double-click Exchange2010-RC1-x64.EXE.

Select a folder to extract the installation files to, and click OK.

Run Setup.EXE.

The installer should consider steps 1 and 2 complete, and gray them out.
Click the link to Step 3: Choose Exchange Language Option.

Click Install only languages from the DVD.

. Click the link to Step 4: Install Microsoft Exchange Server 2007 SP1.

. Click Next to go past the introduction screen.

. Accept the license agreement, and click Next.

. Select No for error reporting, and click Next.

. Select Custom Exchange Server Installation, and click Next.

. Select Mailbox, Client Access Services, and Hub Transport (Exchange will automatically select Exchange

Management Tools as well), and click Add mailbox.

Leave the organization name at default (First Organization), and click Next.

At the question about client computers running Outlook 2003 and earlier, select Yes, and click Next.

Click Next to accept defaults for Configure Client Access server external domain.

At the Customer Experience Improvement Program screen, select | don’t wish to join the program at this time,
and click Next.

If a warning about a lack of SMTP appears after the check finishes, ignore it.

Click Install to start the installation process.

Once installation is complete, click Finish. Exchange should automatically open the Exchange Management
Console.

Configuring Exchange Server 2010 roles

1.

vk wnN

If Exchange does not automatically open the Exchange Management Console, select Start=>All
Programs—> Microsoft Exchange Server 2010 Exchange Management Console.

In the left pane, click Microsoft Exchange On-Premises.

In the left pane, expand Organization Configuration, and select Hub Transport.

In the action pane on the far right, select New Send Connector.

Name the send connector SMTP, select the intended use as Internet, and click Next.
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8.
9.

10.
11.

In the Address space window, click Add.

In the SMTP Address Space window, type * as the address, ensure that the installer has checked Include all
subdomains, and click OK.

Click Next.

Accept defaults for the next two pages by clicking Next.

At the New Connector page, click New to create the connector.

Click Finish to close the New SMTP Send Connector wizard.

Configuring the Exchange Server 2010 Mailbox role

1.
2.

Nousw®

o

10.
11.
12.

13.
14.
15.
16.
17.
18.
19.
20.
21.
22.

23.
24.
25.
26.
27.
28.
29.
30.
31.
32.
33.

Select Start—=>All Programs—>Microsoft Exchange Server 2010 Exchange Management Console.

In the left pane of the Exchange Management Console window, select Recipient Configuration; in the right pane,
select New Mailbox.

In the New Mailbox window, select User Mailbox, and click Next.

In the User Type page, select Existing users, and click Add.

Select the new account you created earlier, and click OK to add it to the selection box.

Click Next.

In the Mailbox Settings window, type tester in the Alias textbox, check the box beside Specify the mailbox
database rather than using a database automatically selected, and select Browse in the Mailbox database
selection.

In the Select Mailbox database window, select Mailbox Database, and click OK.

Click Next.

Click Next.

Click Finish.

In the left pane, expand Organization Configuration and Mailbox so that the Database Management tab is
visible.

Right-click Mailbox Database, and select Properties.

Select the Maintenance tab.

Check the Enable circular logging box.

Check the box beside This database can be overwritten by a restore.

Click Customize next to Maintenance interval.

Remove all blue from the boxes so the system will not perform maintenance, and click OK.

Click OK.

Click OK to any warnings about circular logging being applied after the database is remounted.

On the far right panel, click Move Databases.

Change the Database file and Log folder path locations to E:\Database\(filename) and F:\Maillogs respectively,
and click Move.

If the application prompts you to dismount, click Yes.

Click Finish.

Right-click Public Folder Database, and select Properties.

Check the Enable circular logging checkbox.

Check the This database can be overwritten by a restore checkbox.

Click Customize next to Maintenance interval.

Remove all blue from the boxes so the system will not perform maintenance, and click OK.

Click OK.

On any warnings about circular logging being applied after the database is remounted, click OK.

Click Move Database on the far right panel.

Change the Database file and Log folder path locations to E:\Database\(filename) and F:\Publiclogs respectively,
and click Move.
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34. If the application prompts you to dismount, click Yes.
35. Click Finish.

Preparing VM #3
Installing SharePoint Server 2010

1. Insert the installation DVD, and capture the DVD drive in the VM session.

2. Launch setup.exe, and click Install software prerequisites.

3. At the Welcome to the Microsoft SharePoint 2010 Products Preparation Tool screen, click Next.

4. Accept the EULA, and click Next.

5. When the prerequisites finish installing, click Finish.

6. On the main SharePoint installation menu, click Install SharePoint Server.

7. Enter your product license key, and click Continue.

8. Accept the EULA, and click Continue.

9. Choose the Stand-Alone server type, and click Install.

10. When the installation finishes, check the box for Run the SharePoint Products Configuration Wizard now, and

click Close.
11. On the Welcome to SharePoint Products screen, click Next.
12. On the pop-up warning about services that will need to be restarted during the configuration, click Yes.
13. When the wizard has completed the configuration, click Finish.

Installing and configuring the Exchange 2010 mail test client (LoadGen)

To create the mail client, you must install several software components. Before following these instructions,
make sure to statically assign an IP address for the client, and to then plug that port into the system under test. This
allows the client to join the Active Directory domain. We followed this process for each installation:

Installing Windows Server 2008 R2 SP1 Enterprise Edition

Insert the installation DVD for Windows Server 2008 R2 SP1 Enterprise into the DVD drive.
At the Language Selection Screen, click Next.
Click Install Now.
Select Windows Server 2008 R2 Enterprise (Full Installation), and click Next.
Click the | accept the license terms check box, and click Next.
Click Custom.
Click Next.
At the User’s password must be changed before logging on warning screen, click OK.
Enter the desired password for the administrator in both fields, and click the arrow to continue.
. At the Your password has been changed screen, click OK.
. Click Start, type change power-saving settings and press Enter.
. Click Change plan settings.
. Change the Turn off the display drop-down menu to Never.
. Click Save changes, and close the Power Options, Screen Saver Settings, and Personalization windows.
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To set up this server, we had to install several additional software components. The following subsections detail
the necessary installation processes.

Joining the domain

1. Select Start=>Control Panel->Network Connections—=>Local Area Connection.
2. Click Properties.
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10.

11.
12.

Highlight Internet Protocol (TCP/IP), and click Properties.

Select the Use the following DNS server addresses radio button, and enter the IP of the DNS server in the
Preferred DNS server field. Click OK.

Right-click My Computer, and select Properties.

Under the Computer Name tab, click Change.

In the Computer Name Changes window, under the Member of section, select the Domain radial box, and type
test.local

Select OK to start joining the domain.

When the window appears asking for a person qualified on the domain, type Tester as the username and
Passwordl as the password.

At the welcome pop-up window and the window warning that you must reset the computer for the changes to
take effect, click OK.

At the System Properties window, click OK.

When a pop-up appears asking if you want to restart now, click Yes to restart your computer.

Installing Internet Information Services

L oONOU AWM
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12.
13.

Click Start->Administrative Tools—>Server Manager.

On the left-side pane, click Roles.

Click Add Roles.

Click the Application Server check box.

When the Add features required for Application Server? screen appears, click Add Required Features.
Click Next.

Click Next.

At the Select Role Services page for Application Server, click the Web Server (1IS) Support check box.
Click Next.

. Click Next.
. At the Select Role Services page for Web Server (1IS), click IIS 6 Management Compatibility, ASP, and CGI check

boxes; and click Next.
Click Install.
Click Close.

Installing Load Generator

Download and install Load Generator using all defaults.

Preparing Load Generator

1.

Nous~wnN

o

9.

10.
11.
12.
13.

Log into the mail client using the tester account.

Select Start>All Programs—> Microsoft Exchange—> Exchange Load Generator 2010.

When the Load Generator window appears, select Start a new test.

Select Create a new test configuration, and click Continue.

Change the total length of simulation to 32 minutes.

Verify that the account name is tester.

In the Specify test settings window, type Password]l as the Directory Access Password and Mailbox Account
Master Password, and click Continue with recipient management.

Make 600 users in each Mailbox Database, and click Continue.

To accept defaults for Advanced recipient settings, click Continue.

In the Specify test user groups window, select the plus sign to add a user group.

Change the Client Type to Outlook 2007 Cached, the Action Profile to Average, and the Mailbox size to 100MB.
Check the PreTestLogon check box, and click Continue.

Leave defaults in Remote configurations, and click Continue.
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14. Click Save the configuration file as, and name it 600users—-averagecfg.xml
15. After saving the configuration file, check the Initialize public store as well checkbox, and click Start the
initialization phase (recommended before running the test).

Backing up the mail database

On the Exchange server virtual machine, once you have set up the LoadGen client and created its initial mail
database, you need to back up that database so you can have clean copies for each test.

1. Select Start=>All Programs—>Microsoft Exchange Server 2010 Exchange Management Console in the mail
server.

2. Inthe left pane, expand Organization Configuration and Mailbox.

3. Inthe right pane, right-click Mailbox Database, and select Dismount Database from the menu.

4. Atthe Do you want to continue? pop-up message, click Yes.

5. Right-click Public Folder Database, and select Dismount Database from the menu.

6. At the Do you want to continue? pop-up message, click Yes. The red arrow appears when you have dismounted
the Public Folder Store.

7. Using Windows Explorer, create a new folder: E: \backup\

8. With Windows Explorer, copy all database and public folder files from E:\Database to E:\backup. This process

may take several minutes.
9. Close Windows Explorer.
10. In the Exchange Management Console, right-click Mailbox Database, and select Mount Database from the menu.
11. Right-click the Public Folder Database, and select Mount Database from the menu.
12. Close the Exchange Management Console.

Preparing the SharePoint test client
Installing Microsoft Visual Studio 2010 Ultimate Edition

Install Windows Server 2003 with current updates.

Double-click setup.exe

Uncheck the box for Yes, send information about my computer.

If you see a pop-up requiring a Windows Imaging component, click the Windows Imaging Component is
Required link. If this pop-up does not appear, skip to Step 8.

Click Download on the appropriate Imaging component, and choose Run.
Accept the EULA, and click Next.

Close the pop-up window.

Click Next.

Accept the EULA, review the components to be installed, and click Next.
10 Choose the Full installation and location for the install, and click Install.
11. When the installation prompts you, click Restart Now.

12. Click Finish.

Setting up and running WSSDW 1.0.0.0 Beta

i
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1. Install SharePoint Server 2010 and set up a server farm, as we detail above.

2. Visit http://sptdatapop.codeplex.com/releases/view/1141 and download the following:
e WSS Data Population Tool RunTime.zip
e WSS Data Population Tool.chm
e WSS Performance Load Tests

3. Runthe WSS Data Population Tool sample script, using the following properties:
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<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty
<setproperty

NumberOfSiteCollections="100" />
SiteNameBase="testsite" />
NumberOfGroups="2" />
GroupNameBase="testgroup" />
TargetDomain="test.local" />
DomainGroupRoot="testdomaingroup" />
DomainUserName="test.localadministrator" />
DomainUserPassword="test.localpasswordl" />
DesignerGroup="design" AdminGroup="full control" />
NumberOfDocumentLibraries="5" />
DocumentLibraryNameBasel="testdoclib A" />
NumberOfDocuments="10" />
SourceFileLocation="c¢:\data.txt" />
DestFile="test" />

NumberOfFileVersions="3" />
DocumentLibraryNameBase2="testdoclib B" />
NumberOfLists="10" />
ListNameBase="testlist" />
NumberOfListItems="20" />
webpartpath="webpartpagesfolder" />

4. Set up a performance testing rig with Microsoft Visual Studio 2010 Ultimate Edition. Use multiple test agents if

desired.

5. Copy the provided Visual Studio solution to your test controller machine.

6. Open the serverUrl.csv file located at the root level of the solution folder. (This file contains the server root URL
to be accessed during the tests.)

7. Editthe URLto http://test.local

8. Keep the default port of 80.

9. Modify the following user files corresponding to users with different roles on the site:
e Users.csv - Change domain\userName to test.local\Administrator, Passwordl

e HierarchyManagerUsers.csv — Change domain\userName and password to
test.local\Administrator, Passwordl
10. Open the WssTestProject.sIn file in Visual Studio 2010 Ultimate, and run the following Web tests:

e WSSDispForm

e \WSSDocHTTPFetch

e WSSHomePage

e \WSSSmallDocLibAllltems
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